Closed Bug 1762423 Opened 2 years ago Closed 2 years ago

event details/edit dialog/window/popup/pop-up opens with minimal height, pane content hidden

Categories

(Calendar :: Dialogs, defect)

defect

Tracking

(thunderbird_esr91 unaffected, thunderbird100+ fixed)

RESOLVED FIXED
101 Branch
Tracking Status
thunderbird_esr91 --- unaffected
thunderbird100 + fixed

People

(Reporter: aryx, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Thunderbird 100.0a1 on Windows 8.1

The event edit dialog always opens with minimal height, its pane content is hidden until the user increases the height by dragging the bottom border of the dialog.

Steps to reproduce:

  1. Switch to Calendar view.
  2. Create new event and save edit.
  3. Doubleclick the event to open the details dialog for the event.

Actual result: User has to increase the window height to see the content.

Expect: Content visible

When a line wraps in the dialog then the dialog shows with normal height. Without the line wrap only the titlebar is shown.

Back-out of https://hg.mozilla.org/comm-central/rev/94a1c4858fd6 fixes the issue.

Flags: needinfo?(mkmelin+mozilla)
Keywords: regression
Regressed by: 1703164

(In reply to Richard Marti (:Paenglab) from comment #1)

When a line wraps in the dialog then the dialog shows with normal height. Without the line wrap only the titlebar is shown.

What lines do you mean?
Can't reproduce on linux.

I wonder if "status" was needed after all. https://hg.mozilla.org/comm-central/rev/94a1c4858fd6#l3.46

You're on the wrong platform. ;-) On Mac and Windows it does happen when the entries (Title, Start Date, End Date etc.) are short. When I set it repeating which creates a label that needs wrapping the dialog is shown normally.

Tested a bit. A

#calendar-summary-dialog {
  height: auto;
}

fixes the normal summary dialog but an invitation dialog is still a bit cut off on bottom.

Attached image invitation.png

Invitation with cut off bottom.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mkmelin+mozilla)
Target Milestone: --- → 101 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/db8e312cd5a9
fix event summary dialog sizing issues. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Comment on attachment 9270721 [details]
Bug 1762423 - fix event summary dialog sizing issues. r=Paenglab

[Approval Request Comment]
Regression caused by (bug #): bug 1703164
User impact if declined: on windows/mac the event summary dialog may not be usable
Testing completed (on c-c, etc.): landed on c-c
Risk to taking this patch (and alternatives if risky): very low risk

Attachment #9270721 - Flags: approval-comm-beta?

Comment on attachment 9270721 [details]
Bug 1762423 - fix event summary dialog sizing issues. r=Paenglab

[Triage Comment]
Approved for beta

Attachment #9270721 - Flags: approval-comm-beta? → approval-comm-beta+
See Also: → 1763443
You need to log in before you can comment on or make changes to this bug.