Closed Bug 1703164 Opened 3 years ago Closed 2 months ago

convert top level <window> to <html> throughout the Thunderbird code base

Categories

(Thunderbird :: General, task)

Tracking

(thunderbird_esr78 wontfix, thunderbird_esr115 wontfix)

RESOLVED FIXED
123 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird_esr115 --- wontfix

People

(Reporter: mkmelin, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

(Keywords: leave-open)

Attachments

(145 files, 1 obsolete file)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

Bug 1572062 converted the 3pane. For the most part styling has been adjusted already, and other preparations are now in place.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b31114f27664
convert mail/base/content/messageWindow.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/8f8fada0529c
convert mail/components/compose/content/messengercompose.xhtml to top level <html>. r=henry

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/88da4811edd9
adjust how height is calculated in mail/test/browser/folder-display/browser_openingMessages.js. rs=bustage-fix DONTBUILD
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/bd43c68db6da
convert mail/components/addrbook/content/addressbook.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/d082e65a88d5
convert mail/components/preferences/preferences.xhtml to top level <html>. r=henry

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/50132988e778
Fix the Preference's font size after the HTML conversion. r=aleca

Regressions: 1712535
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ac7596a1da7b
followup: move closing MOZ_OPENPGP to right position. r=henry

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/341d1f02efc5
Convert mail/components/downloads/content/aboutDownloads.xhtml to top level <html>. r=mkmelin DONTBUILD

Is it planned to include feed-subscriptions.xhtml in this party?

My plan is to convert them all, but do it after 91 since there's not a huge rush and it can take time to weed out regressions, which have been subtle but annoying.

@alta88 do you have a phabricator account? Did the conversion, but can't have you review without it.

I don't, the 2FA stuff was disinviting given no usage anymore.

I noticed the layout of this dialog was rather messed up, so fixed it in the process.

It is still rather messed up, with some accumulated regressions along the way. Things that should be done here:

  1. Eliminate the platform specific css (one exception for osx only).
  2. The #selectFolder menu padding/margin has to be adjusted so the detail box doesn't jump when moving from folder to feed item in the tree.
  3. No need for #contentPane margin.
  4. Initial dialog (without persisted xulStore dimensions) is too small; tree is only 2 rows high.
  5. It would be better to use html elements (except tree and menu) and grid/flex model for the detail info box.
  6. themeableDialog doesn't seem to have the dark theme blue for checkbox/radio elements; it either should or maybe preferences.css can be included.

This change
https://hg.mozilla.org/comm-central/rev/d082e65a88d5#l1.103
breaks the ability to build with MOZ_UPDATER disabled. That will affect Linux distros. To fix this, we added

 #ifdef MOZ_UPDATER
   <script defer="defer" src="chrome://messenger/content/aboutDialog-appUpdater.js"></script>
+#else
+  <script defer="defer">
+    var { Services } = ChromeUtils.import("resource://gre/modules/Services.jsm");
+    var { XPCOMUtils } = ChromeUtils.import(
+      "resource://gre/modules/XPCOMUtils.jsm"
+    );
+  </script>
 #endif

Essentially you get XPCOMUtils undefined later on. You may choose to do it some other way.

Regressions: 1719336
No longer regressions: 1719336
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fa72aeb98faa
convert mailnews/extensions/newsblog/feed-subscriptions.xhtml to top level <html>. r=henry
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/649372d0b492
follow-up - Fix a broken test. rs=bustage-fix
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a0a67cd423a5
convert mailnews/base/prefs/content/AccountManager.xhtml to top level <html>. r=Paenglab
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/11d402e3146c
convert mail/components/im/content/addbuddy.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/8319cb118621
convert mail/components/im/content/imAccounts.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/b50b29fc54a7
convert mail/components/im/content/imAccountWizard.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/b3944f15cc0f
convert mail/components/im/content/joinchat.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/42f2868b0007
convert mailnews/base/prefs/content/am-main.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/597a9573fbcc
convert mailnews/base/prefs/content/am-server.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/9fc5dd5898a6
convert mailnews/base/prefs/content/am-serverwithnoidentities.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/eba60e1ccb89
convert mailnews/base/prefs/content/am-copies.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/46578897c7e9
convert mailnews/base/prefs/content/am-junk.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/9c4fbbbb8d05
convert mailnews/base/prefs/content/am-offline.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/0a04b6526c1e
convert mailnews/extensions/mdn/am-mdn.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/76e19f126207
convert mailnews/extensions/newsblog/am-newsblog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/77b3a77849ea
convert mailnews/base/prefs/content/am-addressing.xhtml to top level <html>. r=henry

Convert to top level html, and remove <stringbundle>

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3ff10ed0d3bd
convert ./mailnews/export/content/exportDialog.xhtml to top level <html>. r=henry

This is difficult to trigger. For testing you can just do

window.openDialog(
  "chrome://messenger-smime/content/certFetchingStatus.xhtml",
  "", "chrome,modal,resizable,centerscreen", null, null
);
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/46cffd1b9a85
convert mailnews/compose/content/sendProgress.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/0660a3e1ff9e
convert mailnews/import/content/importDialog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/80542f807639
convert mailnews/import/content/fieldMapImport.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/d262b0cf9324
convert mailnews/extensions/smime/msgCompSecurityInfo.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/b0c1de752f55
convert mailnews/extensions/smime/certpicker.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/eace7e5c001f
convert mailnews/extensions/smime/certFetchingStatus.xhtml to top level <html>. r=henry

For testing, ucomment the last line in onload(), and run

window.openDialog("chrome://messenger/content/shutdownWindow.xhtml",
  "", "chrome,modal,resizable,centerscreen", null, null
);
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/690715e763df
convert mailnews/base/content/shutdownWindow.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/af327c38cbf2
convert mailnews/extensions/newsblog/feedAccountWizard.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/1be6b7b0185e
convert mailnews/base/content/newFolderDialog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/88bebea13f70
convert mailnews/base/content/virtualFolderProperties.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/b87bf19809e3
convert mailnews/base/content/newmailalert.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e5b538bbb148
followup to changeset 88bebea13f70 (virtualFolderProperties.xhtml to top level html) due to test failures in comm/mail/test/browser/search-window/browser_searchWindow.js. rs=bustage-fix DONTBUILD
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4bbf35395a8d
convert mailnews/base/content/msgSelectOfflineFolders.xhtml to top level <html>. r=henry
Regressions: 1734577
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/774194f1c1a8
convert calendar/base/content/dialogs/calendar-invitations-dialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/78d2559050ab
convert mailnews/base/content/folderProps.xhtml to top level <html>. r=henry

I think the ealier work is tripping on <stringbundle> not being present (yet) in the dom.
There is still oddness of event handling with xul:dialog. The can't be where it should be (in head).

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9b58e351e107
virtualFolderProperties <stringbundle> removal. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6b719976f9e3
convert mailnews/base/content/msgSynchronize.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c832cc4bd606
remove no longer needed body class="body" in messenger.xhtml. rs=me
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a849f74066e4
convert mailnews/base/content/virtualFolderListEdit.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/c7b2813a799f
convert mailnews/base/content/subscribe.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/42bfebd9c6d2
follow up to a849f74066e4 - fix linting. rs=eslint DONTBUILD
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/88f84ab6f94b
convert mailnews/base/content/markByDate.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/ec5da861d2b7
convert mailnews/base/content/renameFolderDialog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/7b31c1cfcffb
convert mailnews/base/content/junkLog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/8cbc6a589508
convert mailnews/base/prefs/content/am-card-dialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/867a4c689d51
convert mailnews/base/prefs/content/am-smtp.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/a9aa8a3b9077
convert mailnews/addrbook/prefs/content/pref-editdirectories.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/94a95510772d
convert mailnews/base/prefs/content/am-identities-list.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/62d67f138cfa
convert mailnews/base/prefs/content/removeAccount.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1ff7354b2466
follow-up to 867a4c689d51 - fix linting. rs=eslint DONTBUILD
Attachment #9260829 - Attachment description: Bug 1703164 - convert mailnews/addrbook/content/abCardDAVProperties.xhtml to top level <html>. r=henry → Bug 1703164 - convert mailnews/addrbook/content/abCardDAVProperties.xhtml to top level <html>. r=henry,Paenglab
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2dca250deaa7
convert mailnews/base/prefs/content/SmtpServerEdit.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/1a490ff809b7
convert mailnews/base/prefs/content/am-archiveoptions.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/fc2a3734c4ce
convert mailnews/base/prefs/content/am-identity-edit.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/bd0c98e22865
convert mailnews/base/prefs/content/am-server-advanced.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1869b1083658
convert mailnews/addrbook/content/abAddressBookNameDialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/7f2555122329
convert mailnews/search/content/CustomHeaders.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/f3c39b8ae82f
convert mailnews/search/content/viewLog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/197babe349e1
convert mailnews/search/content/FilterEditor.xhtml to top level <html>. r=henry

This is the dialog one gets by right clicking a contact "Add OTR Fingerprint" context menu.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1090401eeac3
convert chat/content/otr-add-fingerprint.xhtml to top level <html>. r=henry

This is the dialog one gets in chat for "Verify".

For testing use

var paramBlock = Cc["@mozilla.org/embedcomp/dialogparam;1"].createInstance(
  Ci.nsIDialogParamBlock
);
paramBlock.SetNumberStrings(3);
paramBlock.SetString(0, "An error was encountered preparing the calendar located at http://example.com for use. It will not be available.");
paramBlock.SetString(1, "0x12334");
paramBlock.SetString(2, "blablabla");
Services.ww.openWindow(
  null,
  "chrome://calendar/content/calendar-error-prompt.xhtml",
  "_blank",
  "chrome,dialog=yes,alwaysRaised=yes",
  paramBlock
);

For testing

window.openDialog(
  "chrome://calendar/content/calendar-conflicts-dialog.xhtml",
  "calendarConflictsDialog",
  "chrome,titlebar,modal",
  {
  item: { isEvent() { return true}, getProperty() { return "ABC"; }, get calendar() { return { name: "test"} }, title: "Test title" } ,
  mode: "modify",
  overwrite: false,
  }
);

For testing

window.openDialog(
  "chrome://calendar/content/calendar-conflicts-dialog.xhtml",
  "calendarConflictsDialog",
  "chrome,titlebar,modal",
  {
  item: { isEvent() { return true}, getProperty() { return "ABC"; }, get calendar() { return { name: "test"} }, title: "Test title" } ,
  mode: "modify",
  overwrite: false,
  }
);
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/85057d25d733
convert chat/content/otr-finger.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/93e4d449e781
convert chat/content/otr-auth.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/c87146f3e9a8
convert calendar/base/content/preferences/editCategory.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/b60a405286b9
convert calendar/base/content/dialogs/calendar-creation.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5f6ca8ed2cec
follow-up to c87146f3e9a80f9632d35578b67b5d48c6a4e4e6 - fix test. rs=me DONTBUILD
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5ee9579cf4e0
convert calendar/base/content/dialogs/calendar-conflicts-dialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2d2662f7a91f
convert calendar/base/content/dialogs/calendar-occurrence-prompt.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/49793e9acd94
convert calendar/base/content/dialogs/calendar-event-dialog-timezone.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8d19fb20b78a
convert calendar/base/content/dialogs/calendar-alarm-dialog.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/25e0821ebf6d
convert calendar/base/content/dialogs/calendar-error-prompt.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9042d4892485
convert calendar/base/content/item-editing/calendar-item-iframe.xhtml to top level <html>. r=henry
https://hg.mozilla.org/comm-central/rev/94a1c4858fd6
convert calendar/base/content/dialogs/calendar-summary-dialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/0621b33d2f2a
convert calendar/base/content/dialogs/calendar-event-dialog-recurrence.xhtml to top level <html>. r=henry

Backed out the last patch for failures on Windows and possibly one on Mac as well.
https://hg.mozilla.org/comm-central/rev/d0c72993f2bb2a0d4dd2178cb4066340120e34a8

Regressions: 1762423
Regressions: 1746393
Regressions: 1764105
Regressions: 1763443
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8e7632bbfa1d
convert calendar/base/content/dialogs/publishDialog.xhtml to top level <html>. r=henry
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2643d2104b14
convert calendar/base/content/dialogs/calendar-properties-dialog.xhtml to top level <html>. r=henry

(In reply to Pulsebot from comment #96)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/197babe349e1
convert mailnews/search/content/FilterEditor.xhtml to top level <html>.
r=henry

A little overzealous replacement here:
https://hg.mozilla.org/comm-central/rev/197babe349e1#l2.102
https://hg.mozilla.org/comm-central/rev/197babe349e1#l2.152

Regressions: 1773910
Regressions: 1774967
Regressions: 1777291
Regressions: 1777847

Bug 1752288 is open to address the following problem, but I just wanted to add some context here to explain how bug 1752288 is effecting the patches here (taken from https://phabricator.services.mozilla.com/D131063#4271047):

If the window "load" event is fired before a xul:dialog's connectedCallback, then this line throws https://searchfox.org/mozilla-central/rev/9379d512333cb143ed6ee5df5a40274f40d6ce87/toolkit/content/widgets/dialog.js#324 because this._l10nButtons is not initialized. This means that the sizeToContent just below is never called, so the dialog can end up the wrong size.

This can happen because we use <script defer> (https://phabricator.services.mozilla.com/D131063#4279233), but whether it actually happens in usage can come down to seemingly random factors.

So if you (sometimes) see a dialog that does not have the right size and you see in the console

Uncaught TypeError: this._l10nButtons is undefined

this is the origin.

(In reply to Henry Wilkes (they/them) [:henry] from comment #125)

Bug 1752288 is open to address the following problem, but I just wanted to add some context here to explain how bug 1752288 is effecting the patches here (taken from https://phabricator.services.mozilla.com/D131063#4271047):

This same problem seems to be popping up every now and then across bugzilla. Unless we know of a solution to bug 1752288, maybe we should just stop deferring the <script> (as we do here https://searchfox.org/comm-central/rev/cd3088d72a9a397af39540a47a785e31581a8ccc/calendar/base/content/dialogs/calendar-conflicts-dialog.xhtml#30) for all the dialogs touched in this bug.

Flags: needinfo?(mkmelin+mozilla)
Regressions: 1782235
Flags: needinfo?(mkmelin+mozilla)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f14bf2bcae63
convert mail/components/extensions/extensionPopup.xhtml to top level <html>. r=john.bieling

Bug 1752288 is not fully fixed, but for the cases affected just adding the fluent <link> is a nicer workaround.

Easiest way to trigger: set mail.import.in_new_tab to false, then Events and Tasks | Import

To trigger
mkdir -p .evolution/calendar/local
cp foo.ics .evolution/calendar/local
Starting with a new profile, the migration dialog will trigger.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5416b7813b53
Remove workarounds for bug 1752288 since that's now fixed. r=aleca

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/ea1e8c983f04
Fix browser_deletion test by adding fluent link workaround. r=freaktechnik

Attachment #9309084 - Attachment description: Bug 1703164 - convert calendar/base/content/dialogs/calendar-ics-file-dialog.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert calendar/base/content/dialogs/calendar-ics-file-dialog.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e3fc93730056
convert calendar/base/content/dialogs/calendar-ics-file-dialog.xhtml to top level <html>. r=aleca

Goes with D165114 that already landed to avoid re-translation.

It looks like many of these migrations have a string migration for the .title XUL attribute to an HTML <title> element.

To avoid unnecessary re-translation, we can use a migration like in comment 136 (for Fluent-to-Fluent cases). If other cases come up, let's start using migrations since we have the ability now. It will also help with reducing untranslated strings, and let translators work on actual new strings.

Pushed by daniel@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/ff5b4d8b5e79
Fluent2Fluent migration for calendar-ics-file-window-title. r=mkmelin

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/2286eaa047f4
convert calendar/base/content/dialogs/calendar-migration-dialog.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9143759ba745
convert calendar/base/content/dialogs/calendar-providerUninstall-dialog.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/2bc6f7dff22b
convert calendar/base/content/dialogs/calendar-uri-redirect-dialog.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c24b253e7adc
followup - fix linting for 2bc6f7dff22b. rs=black-lint DONTBUILD
Attachment #9316691 - Attachment description: Bug 1703164 - convert mail/base/content/SearchDialog.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/base/content/SearchDialog.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/191604b5663d
convert mail/base/content/SearchDialog.xhtml to top level <html>. r=aleca

Converts to top level html, and fixes the cutoff looks it had (from flexbox emulation removal?).
We don't do anything with encodings here anymore; title updated to reflect that.

Attachment #9321959 - Attachment description: Bug 1703164 - convert mail/components/preferences/fonts.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/components/preferences/fonts.xhtml to top level <html>. r=aleca

Comment on attachment 9322283 [details]
Bug 1703164 - convert calendar/base/content/dialogs/calendar-event-dialog-attendees.xhtml to top level <html>. r=#thunderbird-front-end-reviewers

Revision D172202 was moved to bug 1821435. Setting attachment 9322283 [details] to obsolete.

Attachment #9322283 - Attachment is obsolete: true

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/75f43cc9a96c
convert mail/components/preferences/fonts.xhtml to top level <html>. r=aleca

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1d5741997e8c
convert mail/base/content/FilterListDialog.xhtml to top level <html>. r=aleca

Attachment #9264819 - Attachment description: Bug 1703164 - convert calendar/base/content/dialogs/calendar-event-dialog-recurrence.xhtml to top level <html>. r=henry → Bug 1703164 - convert calendar/base/content/dialogs/calendar-event-dialog-recurrence.xhtml to top level <html>. r=elizabeth
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/85c2f14774a5
convert calendar/base/content/dialogs/calendar-event-dialog-recurrence.xhtml to top level <html>. r=elizabeth
Attachment #9327637 - Attachment description: Bug 1703164 - convert mail/components/compose/content/dialogs/EdInsSrc.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/components/compose/content/dialogs/EdInsSrc.xhtml to top level <html>. r=elizabeth

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/5530ea0fb224
convert mail/components/compose/content/dialogs/EdInsSrc.xhtml to top level <html>. r=elizabeth

Easy way to show this dialog: have more than one calendar, main manu Tasks & Events | Publish.

This is the dialog you get when you create a new event, set reminder | Custom...

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ada176b0b72a
convert calendar/base/content/dialogs/calendar-event-dialog-reminder.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/6d167b8ce8d8
convert calendar/base/content/dialogs/calendar-event-dialog.xhtml to top level <html>. r=vineet
Attachment #9361310 - Attachment description: Bug 1703164 - convert calendar/base/content/dialogs/chooseCalendarDialog.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert calendar/base/content/dialogs/chooseCalendarDialog.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a425257dc607
convert calendar/base/content/dialogs/chooseCalendarDialog.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/96a82584cdcf
convert mail/components/im/content/am-im.xhtml to top level <html>. r=freaktechnik

... and also merge tagDialog.xhtml to newTagDialog.xhtml.

Attachment #9362978 - Attachment description: Bug 1703164 - convert mail/extensions/am-e2e/am-e2e.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/extensions/am-e2e/am-e2e.xhtml to top level <html>. r=freaktechnik
Attachment #9362788 - Attachment description: Bug 1703164 - convert mail/components/preferences/tagDialog.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/components/preferences/tagDialog.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/95c4d03fe844
convert mail/extensions/am-e2e/am-e2e.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5d309017c53a
convert mail/components/addrbook/content/abSearchDialog.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/a2ee039d9638
convert mail/components/preferences/colors.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8d905ce40b7d
convert mail/components/preferences/passwordManager.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/92fa05d14443
convert mail/components/preferences/dockoptions.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/14487b5ef545
convert mail/components/preferences/tagDialog.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/e08c334a556c
convert mail/components/preferences/receipts.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e9bfeafd6178
follow up to 8d905ce40b7d25bd8918730bc7e67b1e309a6324 - fix Fluent refernce. rs=me DONTBUILD

Settings | Files & Attachments | Select a type, choose Application Details in the menu for it.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/46b960804d45
convert mail/components/preferences/cookies.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/e6dc74d807e3
convert mail/components/preferences/attachmentReminder.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/7321f21a2036
convert mail/components/preferences/notifications.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/347e745f63bf
convert mail/components/preferences/messengerLanguages.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/00490fdf5121
convert mail/components/preferences/offline.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/b8b01293acb7
convert mail/components/preferences/permissions.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/273f3a70d420
convert mail/components/preferences/applicationManager.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/88ef6e291837
convert mail/components/preferences/connection.xhtml to top level <html>. r=aleca

E.g. add a bullet list. Format | List Properties... | Advanced Edit...

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c1975399a306
convert mail/components/addrbook/content/abContactsPanel.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/54a3b75f2214
convert mail/base/content/viewSource.xhtml to top level <html>. r=aleca

The dialog you get when you start up with --safe-mode

Compose | (add bullet list) | Format | List Properties...

Test file used by mail/base/test/browser/browser_menulist.js

The dialog you get if you have a few file link providers, add a large attachment and press the Link button in the notification.

The gloda (global search results) wrapper/main document shown when viewing search results.

Compose | (add text and select it) | Format | Table | Crate Table From Selection

Compose | Insert | Horizontal Line. Then double click on the line to bring up the horizontal line properties.

These two files had only minor difference (loading function and section to change addess book the list should belong to at top.)
Merging them before converting to top level html.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d13a051c4c05
convert mail/components/compose/content/dialogs/EdDictionary.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/b6d940c54076
convert mail/base/content/troubleshootMode.xhtml to top level <html>. r=vineet

Customize toolbar, add View. From the View widget, choose the Customize.... Then "New...".

Customize toolbar, add View. From the View widget, choose the Customize...

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d5b3a0a6d5d7
convert mail/base/content/sanitize.xhtml to top level <html>. r=vineet
https://hg.mozilla.org/comm-central/rev/721f0f418a1a
convert mail/base/content/customizeToolbar.xhtml to top level <html>. r=freaktechnik
Attachment #9365585 - Attachment description: Bug 1703164 - convert mail/components/cloudfile/content/selectDialog.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/components/cloudfile/content/selectDialog.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/5db37dd45c2f
convert mail/base/test/browser/files/menulist.xhtml to top level <html>. r=freaktechnik

This is the window used for OAuth2 authentication (showing the UI from the provider asking you to log in).

Attachment #9365801 - Attachment description: Bug 1703164 - merge abEditListDialog.xhtml into abMailListDialog.xhtml. r=#thunderbird-front-end-reviewers → Bug 1703164 - merge abEditListDialog.xhtml into abMailListDialog.xhtml. r=aleca

Setting | System Integration | Check now...
or
On get the dialog at startup.

In the settings, Disk Space, set Compact all folders when it will save over [x] MB.
Delete a message over x size. Later, or at startup, this dialog will pop up.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e54164ab71bb
convert mail/components/compose/content/dialogs/EdInsertTable.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/627a3fc01340
convert mail/components/compose/content/dialogs/EdReplace.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/302d8c97b692
convert mail/components/cloudfile/content/selectDialog.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/af9f369056e5
convert mail/base/content/glodaFacetViewWrapper.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/aa3bf29ada8b
merge abEditListDialog.xhtml into abMailListDialog.xhtml. r=aleca
https://hg.mozilla.org/comm-central/rev/789e1cb679c4
convert mail/components/addrbook/content/abMailListDialog.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/840ab6e15094
convert mail/extensions/mailviews/content/mailViewSetup.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/b4634b4746a4
convert mail/base/content/browserRequest.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/f6bfb3f4d255
convert mail/base/content/systemIntegrationDialog.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/249bf489ed2b
convert mail/base/content/compactFoldersDialog.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d0ae84bf24b7
follow-up to 249bf489ed2b - fix whitespace linting. rs=linting

Import a public key. Once import is done a confirmation dialog is shown - this is that dialog.
It's completely terrible. But, fixing that is not in scope for this bug.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/a72a043a3396
convert mail/components/compose/content/dialogs/EdInsertTOC.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/a074d3f84aba
convert mail/components/compose/content/dialogs/EdAdvancedEdit.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/ac91932f47fc
convert mail/base/content/commonDialog.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/75f20a7bbb6f
convert mail/base/content/hiddenWindowMac.xhtml to top level <html>. r=micahilbery
https://hg.mozilla.org/comm-central/rev/85350f460e08
convert mail/extensions/openpgp/content/ui/enigmailKeyManager.xhtml to top level <html>. r=freaktechnik
Attachment #9366921 - Attachment description: Bug 1703164 - convert mail/extensions/openpgp/content/ui/enigmailKeyImportInfo.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/extensions/openpgp/content/ui/enigmailKeyImportInfo.xhtml to top level <html>. r=freaktechnik
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/51a21e50a1c8
follow-up to 85350f460e08, untangle pointless dependency. rs=bustage-fix
Attachment #9365959 - Attachment description: Bug 1703164 - convert mail/extensions/mailviews/content/mailViewList.xhtml to top level <html>. r=#thunderbird-front-end-reviewers → Bug 1703164 - convert mail/extensions/mailviews/content/mailViewList.xhtml to top level <html>. r=aleca
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/82d5687eb35d
convert mail/components/compose/content/dialogs/EdLinkProps.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/4487cf2a0f30
convert mail/components/compose/content/dialogs/EdImageProps.xhtml to top level <html>. r=elizabeth
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9cd78c91a552
convert mail/extensions/openpgp/content/ui/enigmailKeyImportInfo.xhtml to top level <html>. r=freaktechnik
Regressions: 1869519

This is used internally by EnigmailMsgBox. Can be tested in the console e.g. by

var { EnigmailDialog } = ChromeUtils.import("chrome://openpgp/content/modules/dialog.jsm");
EnigmailDialog.alert(null, "hey hey hey!");

Most/all of this usage should be removed to use standard prompts. But I'm leaving that for now.

On trunk (and sadly I think 115 too) many of the dialogs have their buttons cut off or out of view. This patch fixes that by removing the custom broken dialog resizing.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f2e93dc4ed21
convert mail/components/compose/content/dialogs/EdNamedAnchorProps.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/a688b80339e2
follow-up to 88ef6e291837 - add missing comma. rs=me
https://hg.mozilla.org/comm-central/rev/76ba1111e245
convert mail/components/compose/content/dialogs/EdInsertMath.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/07d4a93ef7ec
convert mail/components/compose/content/dialogs/EdTableProps.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/84bae1b26e39
convert mail/extensions/mailviews/content/mailViewList.xhtml to top level <html>. r=aleca
https://hg.mozilla.org/comm-central/rev/624e28ef538f
convert mail/extensions/openpgp/content/ui/confirmPubkeyImport.xhtml to top level <html>. r=vineet
https://hg.mozilla.org/comm-central/rev/f659b09eb5c6
convert mail/extensions/openpgp/content/ui/keyWizard.xhtml to top level <html>. r=freaktechnik
https://hg.mozilla.org/comm-central/rev/ee3a01b3ce55
convert mail/extensions/openpgp/content/ui/enigmailMsgBox.xhtml to top level <html>. r=aleca

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/43f1c77b83b6
convert mail/components/compose/content/dialogs/EdListProps.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/9ec9ebbcb60a
convert mail/components/compose/content/dialogs/EdInsertChars.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/597895fe4897
convert mail/components/compose/content/dialogs/EdSpellCheck.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/53d64af02375
convert mail/components/compose/content/dialogs/EdConvertToTable.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/31d0c0f84476
convert mail/components/compose/content/dialogs/EdColorPicker.xhtml to top level <html>. r=elizabeth
https://hg.mozilla.org/comm-central/rev/9f318d080137
convert mail/components/compose/content/dialogs/EdHLineProps.xhtml to top level <html>. r=elizabeth

Pushed by elizabeth@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/cee9aa92856f
convert mail/components/compose/content/dialogs/EdColorProps.xhtml to top level <html>. r=elizabeth

That was the last <window> in Thunderbird maintained code, so we're finally done here! Thanks to all the reviewers!
(There's one instance in AccountWizard.xhtml but I'm going to leave it since that that's getting rewritten.)

Target Milestone: --- → 123 Branch
Regressions: 1871983
See Also: → 1873008
Regressions: 1873236
Regressions: 1876325
Status: ASSIGNED → RESOLVED
Closed: 3 years ago2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: