Toolbar customization (temporarily) breaks bookmarks toolbar overflow

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
--
minor
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Tobias Tinkerman, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021023 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021023 Phoenix/0.3

When you go to customize toolbars and have your bookmarks toolbar filled with
items overflowing (showing the overflow arrows), and you click done on the
customization screen, you loose the overflow arrows and wind up with one of your
bookmarks half off the screen.  After, if you minimize the screen and then
Maximize it the overflow arrows come back and the bookmarks toolbar is fine
(takes a second or two), or you can also add another bookmark to get them to
come back.

Reproducible: Always

Steps to Reproduce:
1. Have the Bookmarks toolbar filled to where the overflow arrows appear
2. Open the toolbar customization screen.
3. Click 'Done' (You don't have to actually customize anything)
4. Notice the Bookmarks Toolbar overflow arrows are gone

Actual Results:  
After customization, Bookmarks toolbar overflow arrows disappear.  Have to
minimize/mazimize screen or add another toolbar to get them back.

Expected Results:  
The overflow arrows should re-appear once the customize dialog is dismissed.

Screen Resolution 800X600

Comment 1

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021023
Phoenix/0.3 1280 x 1024

I can confirm this behavior.

Additionally, if you start with the bookmarks toolbar not overflowing, then
lengthen the names of the bookmarks on the toolbar to make the toolbar overflow,
the overflow arrows do not appear and the bookmark quits at the window margin.
Minimizing and then restoring phoenix fixes the display.

Comment 2

15 years ago
Confirming on 20021021 Linux build.

Additionally, doing anything to the toolbar once you come back out of
customization mode, such as deleting or adding a folder, causes the arrows to
reappear.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Comment 3

15 years ago
I don't see this anymore with the 2002/02/27 build running under W2K SP3. I
tested this with the 800x600 and 1024x768 resolutions. Can somebody else take a
look at this.

Comment 4

15 years ago
Good QA'ing, Simon.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
Please reopen.

I see this on 20030226 (granted, this build is one day earlier than the build
reported as WFM, but read on...)

If I do NOT have the location bar or the search bar in the same toolbar as the
bookmarks items, this bug WFM.  But if one or both of those bars exist in the
same toolbar as the bookmark items, the chevron doesn't appear after
Customize...; you have to refresh the window.

Comment 6

15 years ago
djk, please provide a screenshot of your toolbar layout so I can test it here.

Comment 7

15 years ago
Created attachment 116427 [details]
no chevron after customize

I customized toolbars and dragged the search box to the menubar and hit Done.

Comment 8

15 years ago
Created attachment 116428 [details]
improper chevron position after customize

Saw this problem, also.

I customized again and dragged the search box back to the nav toolbar.	The
bookmarks bar width was incorrectly calculated, as the chevron appears too far
to the left.

Comment 9

15 years ago
Note that customizing with a search/location box and overflowed bookmarks on the
same toolbar works if the toolbar with the bookmarks and box doesn't change
during the customizing 'session'.

Comment 10

15 years ago
OK, with build 20030312 W98, I can repro this bug every time.

Patch coming up...  (again, please reopen this bug)

Comment 11

15 years ago
Created attachment 118015 [details] [diff] [review]
explicitly call the bookmarks toolbar resizing function

This patch calls the bookmarks toolbar resize function if the toolbox changed
during toolbar customization.

Comment 12

15 years ago
cc: pch on _this_ bookmarks bug as well... (and bother him for an r=)

Updated

15 years ago
Attachment #118015 - Flags: review?(chanial)

Comment 13

15 years ago
Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
*** Bug 173493 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
worksforme.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Taking QA Contact
QA Contact: asa → bugzilla

Comment 17

15 years ago
I still see this bug on Win98 with build 2003072608, installed in new directory,
new profile created with the build, no extensions.

Steps to reproduce:
1) View -> Toolbars -> Customize...
2) Drag Bookmarks Toolbar Items to the right edge of Navigation Toolbar.
 (see screenshot to follow)
3) Press Done button.

Actual Results:  Bookmarks overflow the edge of the Nav Toolbar
 (see screenshot to follow)

I have not tested my patch with this build to see if it fixes the problem; I
suspect it does.

Thanks,
David

Comment 18

15 years ago
Created attachment 128699 [details]
where to drag the bookmarks toolbar items during customize

Comment 19

15 years ago
Created attachment 128701 [details]
result: bookmarks overflow w/o chevron

Comment 20

14 years ago
I don't want to cause trouble, but could someone please reopen (and/or apply the
simple 1-line patch)?

I just reproduced this bug on:  Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b)
Gecko/20030904 Firebird/0.6.1+

Thanks,
David
Reopening. I see this too with the 2003-09-11 build on WinXP.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
I no longer see this with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7a) Gecko/20040131 Firebird/0.8.0+

The patch is also outdated. Marking WFM.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME

Updated

14 years ago
Attachment #118015 - Flags: review?(p_ch)

Comment 23

14 years ago
I just used the steps in comment 17 to reproduce this bug with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040201 Firebird/0.8.0+
(installed in empty directory, new profile, default theme, no extentions)

I won't attach a screenshot because it looks strikingly similar to the other
screenshots I've attached before. :-}

David

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.