Closed Bug 1762723 Opened 2 months ago Closed 2 months ago

Always first item drag & dropped from downloads list

Categories

(Firefox :: Downloads Panel, defect, P1)

Firefox 99
Desktop
All
defect

Tracking

()

VERIFIED FIXED
101 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox98 --- unaffected
firefox99 --- verified
firefox100 --- verified
firefox101 --- verified

People

(Reporter: tomaz.jandrok, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [fidefe-2022-downloads-followup])

Attachments

(2 files)

Attached image bug.JPG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:99.0) Gecko/20100101 Firefox/99.0

Steps to reproduce:

  1. I downloaded all STL files from this sample project
    https://www.thingiverse.com/thing:5323499/files

  2. When I try to drag & drop the files visible in last downloaded list (not show all downloads) for example to Cura, there is always first downloaded file that is drag & dropped to the Cura (see attachment, where I tried to drag&drop third item in the list. It's the same with second item.).

Actual results:

When I drag & drop any downloaded file from last downloaded files list, first file from the list is always selected & drag & dropped to external program.

Expected results:

If I drag & drop for example second file in the last downloaded files list that should be drag & dropped to external program.

Component: Untriaged → Downloads Panel

Thanks for the report. This looks very similar to bug 1758294. Dão, can you take a look?

Reporter: are you seeing the same thing on more recent versions of beta? (I'm assuming you're on beta...)

Also, to confirm, if you use the library window (show all downloads - ctrl-j on Windows), does dragging from there work correctly?

Flags: needinfo?(tomaz.jandrok)
Flags: needinfo?(dao+bmo)
See Also: → 1758294

I am testing this on beta version 99.0b (released on 8th of March), which is the latest currently on the Firefox website.
If I use library window (show all downloads) drag & drop functionality works correct as expected.
The bug can also be simply seen with just drag & dropping a file from last downloaded list to any folder in explorer on Windows (no external program needed).

Flags: needinfo?(tomaz.jandrok)

it's likely a similar issue indeed, we drag the RLB selected item https://searchfox.org/mozilla-central/rev/26a1b0fce12e6dd495a954c542bb1e7bd6e0d548/browser/components/downloads/content/downloads.js#1045-1046 instead we should probably drag the closest download

Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → Desktop
Whiteboard: [fidefe-2022-downloads-followup]
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Blocks: 1756002
Flags: qe-verify+
Keywords: regression
Regressed by: 1756113
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/14a9df1615c5
Use proper dragstart event targets in the download panel. r=mak

Set release status flags based on info from the regressing bug 1756113

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
Has Regression Range: --- → yes

Comment on attachment 9270746 [details]
Bug 1762723 - Use proper dragstart event targets in the download panel. r=mak

Beta/Release Uplift Approval Request

  • User impact if declined: See comment 0
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0; note that you don't need to drop the download on an external application, the tab bar works too for instance.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial fix
  • String changes made/needed:
Attachment #9270746 - Flags: approval-mozilla-release?
Attachment #9270746 - Flags: approval-mozilla-beta?

Comment on attachment 9270746 [details]
Bug 1762723 - Use proper dragstart event targets in the download panel. r=mak

Approved for 100.0b3

Attachment #9270746 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced with Fx 100.0a1 (2022-04-02) (64-bit) on Windows 10.
Verified fixed with Fx 101.0a1 (2022-04-07) and Fx 100.0b3 on Windows 10, macOS 11.0 and Ubuntu 20.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1763922

Comment on attachment 9270746 [details]
Bug 1762723 - Use proper dragstart event targets in the download panel. r=mak

Approved for 99.0.1.

Attachment #9270746 - Flags: approval-mozilla-release? → approval-mozilla-release+

Verified fixed with FX 99.0.1 on Windows 10, macOS 11.0 and Ubuntu 20.04.

Duplicate of this bug: 1764100
Duplicate of this bug: 1768906
You need to log in before you can comment on or make changes to this bug.