Closed Bug 1763599 Opened 1 month ago Closed 24 days ago

Can't add CardDAV Address Book: "No dirPrefId!"

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED FIXED
101 Branch

People

(Reporter: nicolas, Assigned: darktrojan)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0

Steps to reproduce:

File > New > CardDAV Address Book

Type the login details and WebDAV link https://ecloud.global/remote.php/dav/addressbooks/users/[MY USERNAME]@e.email/[ADDRESS BOOK NAME]/

Enter password

Actual results:

Thunderbird tells me that "ecloud.global is known to be incompatible with Thunderbird" and nothing happens.

Expected results:

It should have imported the address book, I did it a few months ago with another address book from this account and it worked (it's still syncing but I can't import it again as I get the same error message).

Error console says that : NS_ERROR_NOT_AVAILABLE: No dirPrefId!
See attached txt file for more details

By any chance do you have an address book provided by an add-on? I can see how one might cause this problem. If you do, temporarily disabling the add-on should allow you to create the address book.

Thunderbird tells me that "ecloud.global is known to be incompatible with Thunderbird" and nothing happens.

Hmm, this is the wrong message. It should say "Failed to connect." but because the error is NS_ERROR_NOT_AVAILABLE the code assumes it comes from something else.

(In reply to Geoff Lankow (:darktrojan) from comment #1)

By any chance do you have an address book provided by an add-on? I can see how one might cause this problem. If you do, temporarily disabling the add-on should allow you to create the address book.

Thanks, I disabled Owl temporarily and it worked! Do you know if this is still a bug with Thnuderbird?

Thunderbird tells me that "ecloud.global is known to be incompatible with Thunderbird" and nothing happens.

Hmm, this is the wrong message. It should say "Failed to connect." but because the error is NS_ERROR_NOT_AVAILABLE the code assumes it comes from something else.
This is the only error that kept on happening every time I tried.

Thanks for your help!

Sorry this sentence was not supposed to be quoted from you :
"This is the only error that kept on happening every time I tried."

Yes, this is a bug in Thunderbird, not in Owl. I'll get it fixed.

Some address book types (notably the WebExtension API type) may throw an exception when checking their properties. Only check CardDAV directories which won't throw an exception.

Assignee: nobody → geoff
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 101 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/80377006ecff
Avoid exception when checking if a CardDAV directory already exists. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.