Closed Bug 1764070 Opened 10 months ago Closed 10 months ago

A primary button click telemetry ping is sent at upgrade dialog autodismiss

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
101 Branch
Iteration:
101.2 - April 18 - April 29
Tracking Status
firefox99 --- unaffected
firefox100 + verified
firefox101 --- verified

People

(Reporter: mheres, Assigned: mviar)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

[Affected Versions]:

  • Firefox Beta 100.b4 (Build ID: 20220410195727)
  • Firefox Nightly 101.0a1 (Build ID: 20220410213958)

[Affected Platforms]:

  • Windows 10
  • macOS 11.6
  • Linux Mint 20.2

[Prerequisites]:

  • Have Firefox installed and open.
  • Have Firefox set as default browser and pinned if possible.
  • Have “devtools.chrome.enabled” set to “true” from “about:config”.
  • Have “browser.ping-centre.log” set to “true” from “about:config”.

[Steps to reproduce]:

  1. Open the Browser Console (Ctrl + Shift + J).
  2. Run the following command “Cc["@mozilla.org/browser/browserglue;1"].getService().wrappedJSObject._showUpgradeDialog()” in the Browser Console.
  3. Wait for the upgrade dialog to be autodismissed.
  4. Observe the ping displayed in the Browser Console.

[Expected result]:

  • A dismiss ping is displayed.

[Actual result]:

  • A “CLICK_BUTTON” event with the “primary_button” source is displayed.

[Notes]:

  • Attached is a recording of the issue.

Should differentiate between user click and auto dismiss in the primary click pings.

Priority: -- → P2
Assignee: nobody → mviar
Status: NEW → ASSIGNED

[Tracking Requested - why for this release]: Telemetry will be harder to analyze with mixing of user clicks and auto advance/dismiss

Blocks: 1739252
Iteration: --- → 101.2 - April 18 - April 29
Priority: P2 → P1
Pushed by elee@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2219cf6b1481
Differentiate between auto advance and user click when sending Spotlight/AboutWelcome event telemetry r=Mardak

Comment on attachment 9272931 [details]
Bug 1764070 - Differentiate between auto advance and user click when sending Spotlight/AboutWelcome event telemetry

Beta/Release Uplift Approval Request

  • User impact if declined: When the FX100 upgrade dialog is auto dismissed, the event would incorrectly be logged in telemetry as a user action (clicking primary button).
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: With telemetry logging enabled, use run Cc["@mozilla.org/browser/browserglue;1"].getService().wrappedJSObject._showUpgradeDialog() from the browser console to launch the upgrade dialog. Wait until the modal automatically dismisses and confirm that a telemetry event with event_type of "AUTO_ADVANCE" is logged.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change only affects telemetry and should not result in a change to user experience.
  • String changes made/needed: None
Attachment #9272931 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
QA Whiteboard: [qa-triaged]

Thanks all!

I have verified that the issue is no longer reproducible. An "AUTO_ADVANCE" event with the "primary_button" source is recorded at autodismiss (together with a "DISMISS" event). Tested using Firefox Nightly 101.0a1 (Build ID: 20220420094247) on Windows 10, Linux Mint 20.2 and macOS 11.6.

Status: RESOLVED → VERIFIED

Comment on attachment 9272931 [details]
Bug 1764070 - Differentiate between auto advance and user click when sending Spotlight/AboutWelcome event telemetry

Approved for 100.0b9

Attachment #9272931 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that the issue is no longer reproducible on Firefox Beta 100.0b9 (Build ID: 20220420161007) - treeherder builds. An "AUTO_ADVANCE" event with the "primary_button" source is recorded at autodismiss (together with a "DISMISS" event). Tested on Windows 10, macOS 11.6, Linux Mint 20.2.

Flags: qe-verify+
See Also: → 1770745
You need to log in before you can comment on or make changes to this bug.