The Toolbar show/hide widget isn't displayed when window.open() suppresses Toolbar display

RESOLVED FIXED in Camino1.0

Status

Camino Graveyard
Toolbars & Menus
P4
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Ryan Rotter, Assigned: Simon Fraser)

Tracking

({testcase})

unspecified
Camino1.0
PowerPC
Mac OS X
testcase

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021022 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021022 Chimera/0.5+

In Chimera popups that open without the toolbar accessable hide/show toolbar is
deactivated in menubar, and button in upper right hand corner of window is not
present.

Reproducible: Always

Steps to Reproduce:
1.click on link that causes popup to appear(I used Moc OSX link under search
limitations at http://developer.apple.com/search/


Actual Results:  
Toolbar cannot be accessed in popup.  hide/show toolbar is deactivated in
menubar, and button in upper right hand corner of window is not present.

Expected Results:  
Toolbar should be collapsed, as it is, when popup opens.  However, it should be
possible to open toolbar from the menu and with the button in upper right hand
corner of the window.
(Reporter)

Updated

16 years ago
Severity: normal → enhancement

Comment 1

16 years ago
*** Bug 185752 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Confirmed in Chimera/2002121004.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

16 years ago
The main question here is why you would want to get to the toolbar in a popup
window?
Assignee: brade → sfraser
Summary: Toolbar cannot be opened in some popups. → Allow access to toolbar in popup windows

Comment 4

16 years ago
IME
- To access the location
- sometimes popups turn into full-blown browser sessions due to bad design
(Reporter)

Comment 5

16 years ago
Some pop ups contain hyperlinks to pages that will appear in the same pop up
window.  This allows easy navigation between them.  Either way, there is no
practical reason to lock out the tool bar.
(Assignee)

Comment 6

16 years ago
Agreed.
Status: NEW → ASSIGNED

Comment 7

16 years ago
I agree with this poster. I noticed it today on a site that displayed some of
it's content in seperate windows. It was very annoying that the Web page author
had more control over my browser than I did. I could not even copy the URL of
the page without looking at the source of the first page.

Comment 8

15 years ago
I think you can disable this behaviour by adding this line in your prefs.js
file. This will make the location bar visible in all popup windows:

user_pref("dom.disable_window_open_feature.location", true);

Or you can make the menubar always visible where you can then access the menu
options to make any other bar visible:

user_pref("dom.disable_window_open_feature.menubar", true);

Comment 9

14 years ago
Revising summary and severity.
Severity: enhancement → minor
Keywords: testcase
Summary: Allow access to toolbar in popup windows → The Toolbar show/hide widget isn't displayed when window.open() suppresses Toolbar display

Comment 10

14 years ago
Created attachment 145079 [details]
XHTML testcase with various window.open() examples suppressing certain features

Comment 11

13 years ago
For the record, Camino doesn't respect the prefs mentioned in #8, above. Sure
would be nice if it did, though. :)

cl
(Assignee)

Updated

13 years ago
Priority: -- → P4
Target Milestone: --- → Camino1.1
(Assignee)

Comment 12

13 years ago
Fixed; we now allow you to show the toolbar and bookmarks toolbar in chromed
windows.

> user_pref("dom.disable_window_open_feature.location", true);

This pref should work now too.

Currently, you can't show the status bar if it's been hidden by chrome flags,
but gecko defaults to never hiding it anyway. This should be fixed as part of
bug 159233.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Target Milestone: Camino1.1 → Camino1.0
You need to log in before you can comment on or make changes to this bug.