gtk2 build fails with --disable-accessibility

RESOLVED FIXED in mozilla1.2final

Status

SeaMonkey
Build Config
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Tommi Komulainen, Assigned: blizzard)

Tracking

Trunk
mozilla1.2final
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.01 KB, patch
hacker formerly known as seawood@netscape.com
: review+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
gtk2 build tries to compile nsAccessibilityInterface.cpp even if
--disable-accessibility configuration option is used.  This causes the build to
fail because some accessibility interface headers are not found.
(Reporter)

Comment 1

16 years ago
Created attachment 104015 [details] [diff] [review]
Exclude accessibility files if disabled

This patch makes the accessibility related files to be included in the build
only if accessibility is enabled.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
*** Bug 177185 has been marked as a duplicate of this bug. ***
Comment on attachment 104015 [details] [diff] [review]
Exclude accessibility files if disabled

r=cls on the Makefile changes though it'd be nice if one of the gtk2 owners
stepped up and ok'd the patch.
Attachment #104015 - Flags: review+

Updated

16 years ago
Blocks: 92033

Comment 4

16 years ago
(the dupe bug 177185 also has a patch, attachment 104414 [details] [diff] [review])
Comment on attachment 104015 [details] [diff] [review]
Exclude accessibility files if disabled

a=roc+moz for trunk
Attachment #104015 - Flags: approval+
Patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.2final

Comment 7

16 years ago
Hi, Whilst trying to compile trunk of 2002-11-08-08, I got the following errors
when I had --disable-accessibility in my configure line

I was trying to compile a xft+gtk2 build

In file included from nsAccessibilityInterface.cpp:49:
nsAccessibilityInterface.h:45:27: nsIAccessible.h: No such file or directory
make[4]: *** [nsAccessibilityInterface.o] Error 1

If I remove --disable-accessibility from the configure command line, it compiles
successfully
Do we need a gtk2+xft-accessibility tinderbox?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
gtk2 -> blizzard

Assignee: seawood → blizzard
Status: REOPENED → NEW
(Assignee)

Comment 10

16 years ago
There's already a gtk2 tinderbox, but it has accessibility turned on, since
that's important to us.
(Assignee)

Comment 11

16 years ago
This was checked in a while ago.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.