Last Comment Bug 92033 - (gtk2) gtk2 port
(gtk2)
: gtk2 port
Status: RESOLVED FIXED
: access, meta
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Linux
: -- normal with 53 votes (vote)
: ---
Assigned To: Christopher Blizzard (:blizzard)
: Nobody; OK to take it and work on it
Mentors:
Depends on: 120035 121265 131041 160589 160621 162363 173849 179832 186616 195057 196517 197288 197301 gtk2_triage 201158 203671 204621 205425 220430 230943 231408 233371 29856 92034 118296 120034 121246 121248 121251 121252 121253 121254 121255 121256 121257 121258 121259 121260 121262 121263 121264 121266 121613 121615 122131 122429 123197 131043 136315 137106 139726 140698 140867 140868 140873 140878 140896 140897 140900 140902 140903 140904 141075 141077 141081 141092 141094 141239 141669 143991 143993 144212 144215 144421 145601 145863 148065 148309 153805 154348 156093 156593 157438 162250 162507 163257 163358 164994 165558 166138 166202 167782 169094 169096 169108 169340 169635 170919 171461 172103 172203 173225 173640 174058 174471 175947 176299 176341 176514 176518 176556 176708 176713 176716 176842 177405 177665 177905 178045 178067 178145 178404 178501 178732 178764 178805 179078 179138 179181 179512 179657 179667 179740 180052 180123 180147 180309 180319 180500 180700 180841 181053 181233 181404 182130 182162 182575 182726 183303 183370 183389 183518 183841 183912 184599 184612 184670 184941 184956 185160 185299 186510 186567 186621 186789 187029 187280 187335 187388 187931 188156 188996 189229 191072 192999 193618 194180 194186 194299 194306 194323 194407 194610 195104 195414 195708 195817 195868 196008 196177 197041 197658 197911 198082 198284 198502 198954 200060 200917 201209 201220 201501 201944 202388 204090 204248 204310 204664 204870 205226 205492 205594 205752 205981 206361 206554 206713 207001 207255 208721 208762 208763 209342 209496 209606 210931 211788 211834 211907 212824 213747 214412 214583 214715 214779 215032 CTL2 215951 216752 218155 219017 219625 220429 221012 222870 227328 227963 227970 227986 229569 230235 230733 230764 231231 231723 232456 232492 232553 232579 236565 239466 240327 240495 241187 255900 270750 flash-badmatch
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 19:37 PDT by Christopher Blizzard (:blizzard)
Modified: 2015-09-24 15:34 PDT (History)
58 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Christopher Blizzard (:blizzard) 2001-07-23 19:37:58 PDT
Tracking bug for gtk2 work.
Comment 1 Christopher Blizzard (:blizzard) 2001-07-23 19:46:29 PDT
-> blizzard@mozilla.org
Comment 2 John Morrison 2001-08-22 01:41:11 PDT
May God have mercy on us all. The 212 bug spam-o-rama is Now!
Comment 3 Aaron Leventhal 2001-11-16 11:13:30 PST
This will help us support the ATK! (Gnome Accessibility Toolit).
Comment 4 Aaron Leventhal 2002-01-14 10:16:41 PST
Chris, what's the status on this?
Comment 5 Aaron Leventhal 2002-01-14 10:23:41 PST
Looks like the original gtk port is in mozilla/widget/src/gtk
And the gtk2 implementation has been started in mozilla/widget/src/gtk2 

Don't know how much progress was made.
Comment 6 Christopher Blizzard (:blizzard) 2002-01-14 12:16:01 PST
It's trundling along.  I'm making good progress.
Comment 7 Christopher Blizzard (:blizzard) 2002-01-22 10:07:07 PST
If you pull the GTK2_BRANCH branch in gfx/ you should be able to build.
Comment 8 Jay Yan 2002-01-23 18:44:48 PST
Hi Blizzard and Aaron, 
browser China accessibility task force joined in working on this bug. Hope to 
get some help at the beginning.
jay.yan@sun.com
Comment 9 John M 2002-04-22 23:29:45 PDT
Now that 1.1 has branched when is this going in?
Will this be the default build for unix?
Comment 10 Adam D. Moss 2002-06-04 08:28:50 PDT
In regards to the last question, GTK2 isn't released yet
AFAIK let alone percolated through to the average builder's
system so it'll probably be a while before GTK2 becomes the
default FE (even once the GTK2FE work is more or less 'finished',
which I believe it is not).
Comment 11 Luis Villa 2002-06-04 08:39:50 PDT
gtk2.0 is already at 2.0.3, FWIW[1], and I don't think 'the average builder' who
builds /mozilla/ should be at all afraid of building/installing gtk, so that
shouldn't at all be a consideration. That said... gtk2 moz still needs a lot of
love *cough*copyandpaste*cough* before it is even seriously dogfoodable, which I
think is really where the line has to be drawn for making it the default in
unstable branches. Hopefully that won't take /too/ long :) 
[1] And in fact nearly ready for 2.2.0
Comment 12 Adam D. Moss 2002-06-04 08:50:28 PDT
Yikes.  I stand corrected.  I was basing my data
on a spin of GTK2's trunk a month or two ago and
thinking that it was still a long long way from
release quality.  Sorry.
Comment 13 Christopher Blizzard (:blizzard) 2002-06-04 09:17:34 PDT
The gtk2 code has had copy/paste for a couple of weeks now.  See bug 121248
which is closed.

http://lxr.mozilla.org/seamonkey/source/widget/src/gtk2/nsClipboard.cpp
Comment 14 Luis Villa 2002-06-04 10:32:12 PDT
Oh, great. Thanks, Chris.
Adam: it is in pretty good shape; of course, we're always taking bug reports at
bugzilla.gnome.org ;) 
Comment 15 Kyle Yuan 2002-08-29 18:43:40 PDT
mass CCed gtk2 related bugs to browser-china-gtk2@sun.com, remove browser-china-
atf@sun.com from the CC list.
Comment 16 John M 2003-02-13 16:59:29 PST
What is going on with these bugs, there are many many bugs with patches waiting
to be applied. I don't mean to cause a fuss, but blizzard obviously doesn't
have the time to maintain the gtk2 port of mozilla. Could someone please look
at the bugs with patches and get them applied? Nothing has gone in since the
1.3a. A perfect example of this is #183370 there has been a patch with no
complaints for almost 2 months. So Can someone please start applying patches?
Comment 17 Christopher Blizzard (:blizzard) 2003-02-13 19:40:59 PST
I've just been busy with other things, that's all.  I sent robin private email
saying that I was going to start going through some patches by tomorrow.  I
still indend to do that.
Comment 18 Nigel McFarlane 2003-05-06 19:00:26 PDT
Just a polite request that folks dump latest moz-gtk2 progress
into bugzilla. Those of us attempting to document mozilla's
surface and insides are in planning mode on gtk2 next week.
Can we see the latest?  Yes, it sounds insane to think about
docs before the code is finished, but that's the way it is.
Comment 19 Christopher Blizzard (:blizzard) 2003-05-07 09:38:36 PDT
I don't think we really have any docs.
Comment 20 Nigel McFarlane 2003-05-07 18:03:22 PDT
Thanks Chris.  Not looking for docs; just want to be sure that
remaining bugs are up to date when planning for future docs
occurs. Recent comments here indicate that gtk2 status changes
are sometimes batched up and only hit bugzilla much later.
This is just a request that any outstanding status
changes and resolved issues be pushed into bugzilla.
Updates to any tree or from-the-coalface docs would
be celebrated at a separate party.
Comment 21 Christopher Blizzard (:blizzard) 2003-05-08 06:33:52 PDT
This bug indicates the state of the port.  I don't think there's any batching up
going on here.
Comment 22 Christopher Blizzard (:blizzard) 2008-10-14 06:33:29 PDT
Marking fixed.  This was done a few years ago.

Note You need to log in before you can comment on or make changes to this bug.