Closed Bug 1765685 Opened 2 months ago Closed 2 months ago

Massive flickering glitches on Customization page (content from previous tab, transparent window, smeared content)

Categories

(Firefox :: Theme, defect)

x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
101 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox99 --- wontfix
firefox100 --- verified
firefox101 --- verified

People

(Reporter: jan, Assigned: emilio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: correctness, nightly-community, regression)

Attachments

(3 files)

Attached video 2022-04-21_04-25-01.mp4

Debian Testing, Gnome Wayland, Intel

STR:

  1. Install https://addons.mozilla.org/en-US/firefox/addon/somber-forest/,
  2. right click on toolbar, click "Customize Toolbar",
  3. resize browser.

mozregression --good 2021-06-01 --bad 20220420215300 -a https://addons.mozilla.org/en-US/firefox/addon/somber-forest/

16:24.77 INFO: Last good revision: e3ed61b61357e78f89a316d68dd5cc69ffd099ac
16:24.77 INFO: First bad revision: eb8c23dda78d3ed4bf244c3e72c76e81833086ff
16:24.77 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e3ed61b61357e78f89a316d68dd5cc69ffd099ac&tochange=eb8c23dda78d3ed4bf244c3e72c76e81833086ff

eb8c23dda78d3ed4bf244c3e72c76e81833086ff Emilio Cobos Álvarez — Bug 1509931 - Use titlebar radius on Linux and make titlebar set-up work for lightweight themes. r=stransky,dao

Attached file aboutsupport.txt

mozregression --launch 20220420215300 -a https://addons.mozilla.org/en-US/firefox/addon/somber-forest/ -a about:support

$ dpkg -l libgtk-3-common mutter-common libegl-mesa0 *adwaita*

adwaita-icon-theme 42~really41.0-1
libadwaita-1-0:amd64 1.1.0-1
libegl-mesa0:amd64 21.3.7-1
libgtk-3-common 3.24.33-1
mutter-common 42.0-3

:emilio, since you are the author of the regressor, bug 1509931, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

I think the theme does not specify background color or background color is transparent.

Assignee: nobody → emilio
Flags: needinfo?(emilio)

The Linux compositor relies on the tab area being fully opaque, all the
time. This I'm almost sure also fixes bug 1762379, since alpenglow also
has a semi-transparent toolbar-bgcolor.

Why does transparency flicker this way?
Is gtk double buffering still enabled somewhere (bug 1502519 comment 27)?

Duplicate of this bug: 1762379
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c586eae9c25
Ensure customization mode is opaque. r=dao
Component: Widget: Gtk → Theme
Product: Core → Firefox
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
Status: RESOLVED → VERIFIED

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9273211 [details]
Bug 1765685 - Ensure customization mode is opaque. r=dao

Beta/Release Uplift Approval Request

  • User impact if declined: flickering in customize mode with some themes.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0 and duplicate bug.
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Pretty simple CSS change.
  • String changes made/needed: none
  • Is Android affected?: No
Flags: needinfo?(emilio)
Attachment #9273211 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9273211 [details]
Bug 1765685 - Ensure customization mode is opaque. r=dao

Approved for 100.0rc1

Attachment #9273211 - Flags: approval-mozilla-beta? → approval-mozilla-release+
QA Whiteboard: [qa-triaged]

Hello,

Reproduced this issue on Ubuntu 20.04 with 101.0a1(20220419214607).

Confirming this issue as verified fixed on Ubuntu 20.04 with 101.0a1(20220426094609) and 100.0 20220425210429.

You need to log in before you can comment on or make changes to this bug.