msn.com - Form submission on one of MSN's pages to obtain the software is not functional.

RESOLVED FIXED in Future

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: lchiang, Unassigned)

Tracking

unspecified
Future

Details

(URL)

(Reporter)

Description

15 years ago
Form submission on one of MSN's pages to obtain the software is not functional.

https://bbrac.msn.com/msn8/nb/msnsignup.asp?rpn=MSNIA_MSNIABYOAPP&pgmarket=en-us&RU=http%3a%2f%2fjoin.msn.com%2f%3fpage%3dmisc%2fspecialoffers%26pgmarket%3den-us

1.  Go to above URL
2.  Click Continue button. 
3.  Nothing happens

Reproduced on 1.0 branch build (from 10-14-2002) and a recent trunk build
2002-10-24-08 win32 build.   Communicator 4.7x doesn't even show the Continue
button.  IE works fine.

Stephen believes this to be similar to: 
http://bugzilla.mozilla.org/show_bug.cgi?id=163240

Stephen helped me look at the JS Console:

technutz (7:07:27 PM): here's the code in question:
technutz (7:07:28 PM): frmNewUserForm.ExistingUser.value = "1";
			if (ValidateData()){
				frmNewUserForm.action="plans.asp";
				Image2.disabled = true
   				bNext = true;
				frmNewUserForm.submit();
LisaChiang (7:07:35 PM): what does that mean?
technutz (7:07:57 PM): if the return value of ValidateData()'s function is valid
technutz (7:08:08 PM): then the action is "go to plans.asp" on the current URL.
technutz (7:08:24 PM): (then, they disable the back button and enable the next
button)
technutz (7:08:35 PM): and they call the submit() method on frmNewUserForm
LisaChiang (7:08:37 PM): that's the code that is not working then?
technutz (7:08:41 PM): yup
LisaChiang (7:08:53 PM): I wonder if it is them.  Let me try 4.x.
technutz (7:10:18 PM): since it doesn't work on either case
technutz (7:10:28 PM): it's safe to say it's the submit function itself which
isn't working
Here's the real bug:

Error: frmNewUserForm is not defined
Source File:
https://bbrac.msn.com/msn8/nb/msnsignup.asp?rpn=MSNIA_MSNIABYOAPP&pgmarket=en-us&RU=http%3a%2f%2fjoin.msn.com%2f%3fpage%3dmisc%2fspecialoffers%26pgmarket%3den-us
Line: 40

Comment 2

15 years ago
looks like evangelism, isn't?
They're using a raw element ID to refer to an element. IE supports that; we do
not and have no plans to.  A bit of getElementById() love would help here.
Assignee: alexsavulov → susiew
Component: Form Submission → US General
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: vladimire → zach
Hardware: PC → All
Version: other → unspecified

Comment 4

15 years ago
mine
Assignee: susiew → bclary
Blocks: 114158

Comment 5

15 years ago
contacted.
Status: NEW → ASSIGNED
Summary: Form submission on one of MSN's pages to obtain the software is not functional. → msn.com - Form submission on one of MSN's pages to obtain the software is not functional.
Target Milestone: --- → Nov

Updated

15 years ago
Keywords: evang500

Comment 6

14 years ago
not fixed. I guess they don't need new business.
Assignee: bc → english-us
Status: ASSIGNED → NEW
QA Contact: zach → english-us
Target Milestone: Nov → Future

Comment 7

14 years ago
similar to bug 163240 and fixed as well i think.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.