Closed Bug 176675 Opened 22 years ago Closed 20 years ago

Dragging links to the URL bar doesn't work as expected

Categories

(Firefox :: Toolbars and Customization, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: thieleke, Assigned: bugzilla)

References

Details

Attachments

(1 file, 1 obsolete file)

Dragging text or links to the URL Bar just appends the text to current URL bar
contents.  

This should be changed since Internet Explorer automatically loads links that
are dropped on its URL bar (it refuses plain text).  Also, highlighing text and
dragging it to the URL bar is a very convienient way to do a keyword search. 
This particularly true on on Windows, since it saves a copy/URL bar select/paste
operation.
Attached patch dragdrop handler for the URL bar (obsolete) — Splinter Review
This patch adds the drop handler for the URL bar, so dragging text or links are
automatically handled as though the user entered the data into the URL bar and
submitted it.
For consistancy, and also by request
(http://www.mozillazine.org/talkback/read.php?f=15&i=967&t=965), I've added a
drop handler for the search-bar as well.
Attachment #104129 - Attachment is obsolete: true
Keywords: patch
Confirming

The same occurs if you drag and drop to the search box.
The cursor focus should also be changed to the URL/search bar so pressing Enter
will carry out the search.
Comment on attachment 104238 [details] [diff] [review]
URL and Search bar ondragdrop handlers

blake, can you review this patch? Thanks.
Attachment #104238 - Flags: review?(blaker)
*** Bug 57228 has been marked as a duplicate of this bug. ***
Jason, is it right to mark 57228 as a dupe of this, as this bug is specifically
for Phoenix and the other one is for mozilla?
Hmm.  Perhaps I was too quick here.  I'll reopen bug 57228 - and apologize for
the noise.
Taking QA Contact
QA Contact: asa → bugzilla
Confirming bug still present on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030804 Mozilla Firebird/0.6.1
*** Bug 231430 has been marked as a duplicate of this bug. ***
-> me
I just fixed the urlbar part of this but I crash when trying to make it work for
the search bar.
Assignee: hyatt → firefox
Attachment #104238 - Flags: review?(firefox)
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040217 Firefox/0.8.0+
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040217 Firefox/0.8.0+

This fix does cause a crash for me if the urlbar is blank.
For those that don't know, you can drag links to the Go button or a different
window to load it in Mozilla, Mozilla Firefox, and IE. With Mozilla and Firefox,
you can even drag non-hyperlinked URLs and have them load.
The checkin for this also created an error if the user doesn't have the URL bar
added to their toolbar (I know that the Open Location dialog is broken anyway
but that's easy to fix). Could you add an "if (gURLBar)" check in front of the
"gURLBar.addEventListener..." bit, not sure if I should file a separate bug for
this?
Okay, I added the check and the search bar part of this and also added a
semi-lame  workaround for the crash.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
any chance of getting a hidden pref to disable this?  i prefer the old behavior.
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: