Closed Bug 1767863 Opened 16 days ago Closed 7 days ago

Default field validation messages do not zoom with page

Categories

(Core :: Layout: Form Controls, defect)

Firefox 100
Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1756203
Tracking Status
firefox-esr91 --- wontfix
firefox100 --- wontfix
firefox101 --- wontfix
firefox102 --- wontfix

People

(Reporter: aroselli, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

  1. Visit https://platform.sitelint.com/login
  2. Submit the form with both fields blank.
  3. Observe the error messages use default browser/HTML validation and display.
  4. Zoom the page (ctrl + +).

Actual results:

The error message does not scale up (zoom) with the rest of the controls or content on the page.

Expected results:

The error message should zoom with the content and native controls (unless those are expressively overridden, in which case the error messages should scale anyway). If I zoom to 200%, the error message text should be at 200% of its initial size, wrapping as appropriate to stay within the viewport.

In the attached video, I only zoomed to 170%. Compare the text size in the error message at 0:01 and 0:09 — it is not 170% larger at 9 seconds.

I was able to reproduce this on Mac 11 and Windows 10 as well.

It does seems to be a duplicate of Bug 1405864 but that is a very old report that might've been forgotten.

Thank you for reporting!

Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
See Also: → 1405864

Oops, I did not see that one in my search else I would have added to it.

FWIW, this occurs on the password field and regular text fields (type="text") as well. This site just happened to be an easy example for filing the issue.

bug 1756203 is about this bug for text fields, essentially (and we kinda broadened it to include all similar "in-content" popups/dropdowns).

I'll mark this bug and bug 1405864 as duplicates of bug 1756203 since we've had a good amount of discussion there, and we don't want to rehash that same discussion on several independent bugs.

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1756203

(Also, I should've started with: thank you for the bug report! :) )

You need to log in before you can comment on or make changes to this bug.