Closed Bug 176850 Opened 19 years ago Closed 19 years ago

bring over mscott's thread pane "view" code from ns, to mozilla

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.3alpha

People

(Reporter: sspitzer, Assigned: sspitzer)

References

Details

Attachments

(3 files, 5 obsolete files)

bring over mscott's thread pane "view" code from ns, to mozilla.

we should find any bugscape bugs on the feature, and bring them over to
bugzilla, too.

note, we might not be able to turn it on fully, until we've finished all the
filter changes.  I'll elaborate on that in this bug, and the meta bug I'll log
about when we can fork rules.dat (if that bug doesn't already exist)
Blocks: 168553
No longer depends on: 168553
QA Contact: olgam → laurel
taking.
Assignee: dmose → sspitzer
good news, I've open sourced mscott's work.  it's not on by default yet, since 
we are frozen for 1.2 final

it will be on by default (At least for windows and linux) in 1.3 alpha
Status: NEW → ASSIGNED
could you explain what this change is all about?
Oh, it's a virtual/search folders type thing. Nice!
firstly, thanks a lot for this feature!

secondly, I now applied the patch and built it, and it has a small problem...
(well, maybe it's designed like this...):
I usually have mozilla set up to only show unread mail (view|messages|unread).
now, if I have that option set, and click "All" in the new dropdown list, I
still don't get all messages, but only the unread ones. would be great if this
would show all.
*** Bug 164092 has been marked as a duplicate of this bug. ***
Target Milestone: --- → mozilla1.3alpha
for mike lee (and others) a screen shot of how you customize views.

it's the advanced search UI.
I just noticed that it's not possible to show mails/newsgroup postings
threaded... this would be so much more useful if that was possible.

also, I wish that the view would reset to "All" when I switched from Mail to
News; although if threaded display mode were possible, this would not be so much
of a problem.
Looks great, but can it be used in usenet also? 'Recent' filter would be
especially useful in newsgroups. Also thread view when filtered would be great.
henrik asks:

> are views cross folders?

No, single folder.  That idea (virtual folders) is still an open RFE.
Cross folders would be doable, as would cross accounts, but the latter would
take more work.

Here's something I've been doing, to simulate virtual folders.

1)  disable my filters 
  a) if sender contains bugzilla, then ...
  b) uf subject contains "adv: ", then ..
2)  create three custom views instead:
  a) sender contains bugzilla
  b) subject contains "adv: "
  c) and sender doesn't contain bugzilla and subject does not contain "adv: ".
3)  view my inbox in mode (c).  instead of switching folders, I just switch views.
>Looks great, but can it be used in usenet also? 'Recent' filter would be
especially useful in newsgroups.

yes, works in news.  

but right now you can't thread when you are in a view mode.
known bug:  after using the customize view, the view picker says "customize..."
instead of what it was before.  (might only be if you do customize and then hit
cancel)
Seth, do you want to only check this in for 1.2 as an extension that doesn't
touch other code?
> Seth, do you want to only check this in for 1.2 as an extension that doesn't
> touch other code?

I wanted to know if drivers wanted it for 1.2 final, but I should wait for 1.3
alpha.

there's some issues, we need to wait for rules.dat to fork (bug owned by naving)
and I still need to do the mac project work.
Yeah, let's wait for 1.3a.
*** Bug 162246 has been marked as a duplicate of this bug. ***
Talked with Seth.  Laurel, pls bring the open bugs on this feature from bugscape
over to bugzilla now that the code is open sourced. Thanks.
turned on for windows and linux, mac coming soon.
Attached patch .xml files already checked in. (obsolete) — Splinter Review
Attachment #104921 - Attachment is obsolete: true
Attached patch patch, -uw this time (obsolete) — Splinter Review
Attachment #105370 - Attachment is obsolete: true
fixed, on all platforms.

also, I forgot to package up mailViews.dat, so that meant today's builds didn't
have a default mailViews.dat, but tomorrow's will.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Something missing from the installer build? The feature is not visible in
installer build trunk-2002110808 on WinXP, but the zip package works.
Doesn't work in yesterdays nightly on Mac either. I had to manually add

content,install,url,jar:resource:/chrome/messenger.jar!/content/messenger-views/

to installed-chrome.txt. My own trunk build works fine.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hmm, adding that line to installed-chrome.txt still doesn't allow my custom
views to show up in the list of mail views in an rpm build.  Something is still
missing.
Still have the problem of no MailViews showing up (evein with added line) in
latest builds -- 2002111404 (Both ZIP & SEA Build tested).
Correction:  I overwrote the SEA build dir with the ZIP build ... After deleting
install dir and unzipping, MailViews are back ... current ZIP build works (on
clean install, :) )
This still doesn't work in Mac nightlies, have to manually add the line to
installed-chrome.txt every time.
Anyone else have the problem that their ADVANCED button wen taway (allows Search
Messages) ... This only happens once you get the VIEW button back up .. 
ok, I just double checked that today's trunk linux bits
(mozilla-i686-pc-linux-gnu-sea.tar.gz) are ok.

peterv says mac is hosed, looking into that now...
Status: REOPENED → ASSIGNED
ruh-ruh, three mailnews related lines appear to missing from the official mac
installed-chrome.txt file

> content,install,url,jar:resource:/chrome/messenger.jar!/content/messenger-mdn/
> content,install,url,jar:resource:/chrome/messenger.jar!/content/messenger-views/
> locale,install,url,jar:resource:/chrome/en-US.jar!/locale/en-US/messenger-mdn/

working it...
Bug 183755 might be the same issue...
looks like I forgot to add lines to the per platform mail.jst files
(I'll double check with ssu)

not sure why it works for win32 / linux, though.

working on it...
Attached patch jst file cleanupSplinter Review
sure enough, some of these .jst changes were in the ns tree, which is why
people behind the firewall weren't seeing it (on linux / win32)
Attachment #105373 - Attachment is obsolete: true
Attachment #105374 - Attachment is obsolete: true
Attachment #105375 - Attachment is obsolete: true
I think we want this for 1.3a, I'll go seek reviews...
Flags: blocking1.3a?
*** Bug 183755 has been marked as a duplicate of this bug. ***
Attachment #108417 - Flags: superreview?(bienvenu)
Attachment #108417 - Flags: review?(ssu)
Comment on attachment 108417 [details] [diff] [review]
jst file cleanup

sr=bienvenu
Attachment #108417 - Flags: superreview?(bienvenu) → superreview+
Attachment #108417 - Flags: review?(ssu) → review+
Comment on attachment 108417 [details] [diff] [review]
jst file cleanup

seeking approval.
Attachment #108417 - Flags: approval1.3a?
Comment on attachment 108417 [details] [diff] [review]
jst file cleanup

a=asa for checkin to 1.3a
Attachment #108417 - Flags: approval1.3a? → approval1.3a+
fixed.  but the proof is in the pudding, when tomorrow's bits come out.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
Flags: blocking1.3a?
Works for my Mac nightlies now.
Great, also works in Windows installer build now.
I just tested today's mozilla mac and linux bits, they seem ok too.
marking verified
OK using dec23 commercial trunk: win98, linux rh8.0, mac OS 10.2
Generally in an functional
Any further, specific issues for this views feature should be logged separately.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.