Closed Bug 1768694 Opened 2 years ago Closed 1 year ago

Mute/Unmute is out of sync with original video on ici.radio-canada.ca

Categories

(Toolkit :: Picture-in-Picture, defect, P3)

defect

Tracking

()

VERIFIED FIXED
113 Branch
Tracking Status
firefox113 --- verified
firefox114 --- verified

People

(Reporter: niklas, Assigned: yasminekaltouma)

References

Details

(Keywords: good-first-bug)

Attachments

(1 file)

STR:

  1. navigate to https://ici.radio-canada.ca/info/videos/media-8607193/2460-entrevue-avec-michel-tremblay-immortel
  2. open a PiP window
  3. mute the video and observe that the original video is still unmuted
  4. close the PiP window and play the video

Actual results:
The video plays in a muted state but the volume indicator shows the video is unmuted.

Expected results:
The mute state should change on the original video when mute is clicked from the PiP window

Severity: -- → S3
Priority: -- → P3
See Also: → 1768435

This mute method is responsible for muting the sound from the PiP window. The fallback, when no video wrapper exists for a particular site, sets video.muted to true or false. While this does mute the sound for ICI Radio Canada, it would be better to select the mute button on ICI Radio Canada instead, like we do for airmozilla for example.

To make a script that can do this, we need a brand new video wrapper for ICI Radio Canada. Please see how to make a video wrapper here.

Keywords: good-first-bug

Hello,
may I work on this bug?

Hello, thank you for your interest! I assigned the bug to you. Please reach out if you have any questions. Otherwise if there's no activity on the bug after a couple days, I might unassign the ticket to give other applicants a chance to work on a patch.

Assignee: nobody → yasminekaltouma
Status: NEW → ASSIGNED

Thank you. I'll submit a patch soon.

Pushed by kpatenio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/412ec6ee13cf
Mute/Unmute is out of sync with original video on ici.radio-canada.ca. r=kpatenio
Duplicate of this bug: 1775539
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
QA Whiteboard: [qa-113b-p2]

Reproducible on a 2023-03-12 Nightly build on macOS 12.
Verified as fixed on Firefox 113.0(build ID: 20230501151611) and Nightly 114.0a1(build ID: 20230502160708) on macOS 12, Windows 10, Ubuntu 22.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-113b-p2]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: