Closed Bug 177036 Opened 20 years ago Closed 19 years ago

"Save image as..." download the image again for big images

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 120809

People

(Reporter: neo-8ba, Assigned: bugzilla)

Details

I won't give you the url (that's a 2.8MB jpeg image, and i don't want to put
stress on the poor server), but when you do "save image as..." on a big image,
it downloads the image again, putting unnecessary charge on the server.
The url is of the type http://www.foo.com/foo/foo.jpg, so there isn't any html
involved.
If you can not reproduce the bug, i can eventually provide the url to the bug's
owner.
This bug is related to bug 143949, since it should not even trigger the download
manager.
I think the problem is likely that the image is just not in cache (because it's
so big)..
I am not a developer, but the image must be somewhere to be displayed.
Anyway i think that it's a wrong behaviour and that it should be corrected.
With problems like this, Mozilla won't become popular amongst the webmasters who
pay their bandwidth.
Sidenote: Internet explorer has not this problem.
I can confirm this behaviour on Firebird 0.6. Large images are redownloaded even
if they should be in cache. I went to my \temporary internet files and deleted
everything. I ran Firebird with -newprofile. The behaviour is still there. I am
positive Phoenix didnt behave like this, so I'd say it's a bug.
agreed

*** This bug has been marked as a duplicate of 120809 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.