'save image' files are added to download manager

RESOLVED WONTFIX

Status

()

defect
--
major
RESOLVED WONTFIX
17 years ago
3 years ago

People

(Reporter: jens-uwe, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: parity-opera)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.0+) Gecko/20020511
BuildID:    2002051121

if you have a picture in an HTML file and you make 'save picture', then this
file is added to the download manager. 
Since the picture is very likely to be already there, I doubt that this is a
good behaviour. Together with the not yet fixed bug 132755 this might get really
annoying if used often.

Reproducible: Always
Steps to Reproduce:
1. go to www.mozilla.org
2. go with the mouse to the mozilla banner
3.make a right mouse click and go to 'save image as' and save the file
4. look into the download manager

Actual Results:  the file mozilla-banner.gif is added to the download manager

Expected Results:  it shouldn't
Yes, I just noticed that this is happening (I am pretty sure it did not used to
happen).  Also happens for HTML files you save using "File | Save Page As..." or
from context menu "Save Page As..."
Did either of these used to happen?  I can't remember for sure.
-=Win 98 2002051208=-
I think desired behavior is only resources that are not already in cache when
user asks to save them should invoke download manager, or something like that,
right?
From n.p.m.general:
"Gradually over the last month and a half, the action of saving an image from a
webpage has slowed down more and more.  Nowadays, after I click <OK>, there is a
delay of at least 3 seconds---sometimes up to 6 seconds---before the little
status window appears."
Keywords: perf
OS: Linux → All
Hardware: PC → All
I think this is causing bug 157864. Since every single saved image started going
into the download manager, the downloads.rdf file has bloated rapidly. I was
experiencing delays of several seconds downloading any file or saving an inline
image off a page. I deleted downloads.rdf (about 920KB) and the problem went
away. This is even though I wasn't using the download manager, just the progress
dialog.

Side note: You ought to make the download manager clean itself up more often anyway.
Depends on: 120809
See also bug 66723, the equivalent bug when download manager is disabled in
favor of progress windows.
Severity: normal → major
Whiteboard: parity-opera
QA Contact: sairuh → petersen
This behaviour is not only irritating, it doesn't even provide the information
you'd expect it to anyhow. Downloads from cache are all listed as "1KB of 1KB"
in the transferred column, no matter what the file size is.
*** Bug 210346 has been marked as a duplicate of this bug. ***
Nominating for FF 1.0. There is a strong difference to the NS4.x & old Moz Suite
behaviour. There was, indeed, a "saving..." pop-up then but it was lasting for
only a few hundred msec. While DM remains there until user closes that window.
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Product: Browser → Seamonkey
This is still happening in FF 1.5 beta2 !
Download manager is opened each time an image is saved.
This is useful when you save images via Save Link As... or directly typing in the location bar. For dial-up users, it's useful to track download progress for large images. Not that it doesn't get annoying after a while, but overall, I'd like to see the current behavior continue.
Assignee: bross2 → download-manager
QA Contact: chrispetersen
Assignee: download → nobody
Component: Download & File Handling → Download Manager
Product: SeaMonkey → Toolkit
QA Contact: download.manager
Blocks: 144388
Is this still considered "major"?
Duplicate of this bug: 874445
I don't see any reason to change this behavior (the behavior change introduced 11 years ago isn't worth revisiting now).
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: perf
Resolution: --- → WONTFIX
Gavin,

first, since the 2002 report it was still unclear if this was a pending bug or a desired feature. Comments tend to consider this as something annoying. I also do.

Then the big point is that now that the context is worse. The automatic "Clear Download history when Firefox closes" is broken (see bug 847627 and bug 876476), the download list is getting very large and saved images are making difficult to find real downloads. For this reason I think this "bug-or-feature" should be at least reopened for discussion.

Thank you.
(In reply to bahamut00 from comment #13)
> bug 876476), the download list is getting very large and saved images are
> making difficult to find real downloads. For this reason I think this
> "bug-or-feature" should be at least reopened for discussion.

That's only a problem if you're very frequently saving images, and don't think they're "real downloads". If we change this behavior now we're just as likely to get complaints from people who want to easily keep access to their saved images in one place, etc. We can't cater to both sets of users, and we don't have any strong arguments in favor of one or the other behavior, so we default to the status quo.
Saved images are just not downloads, and I don't why people would expect to find them in the download list. Same for saved pages as far as I can see.

But probably I don't see the utility of the "download" list, and I can get it always empty anymore. All this makes my privacy a bit worse with firefox, but this is the subject of another bug report.
(In reply to bahamut00 from comment #15)
> Saved images are just not downloads, and I don't why people would expect to
> find them in the download list.

I think you could say that about something that takes no time to download, that is you can expect it to be downloaded if no error message appears immediately.

Would you call saving a WebM video that is being played in a tab not a download?  Saving an image or a page also can take significant time.
I do not call "download" saving something which is already displayed in front of me. I call this "save a copy as".

I call "download" the result of the conscious action of saving a file by e.g. clicking on a link which invokes the download manager. The download may be instantaneous if file is small or already in cache, but I explicitly asked for this action. This perfectly includes images as long as they are saved with "save link as".

There is a clear difference in users mind. As for now the download manager is used for things which are not download requests, this does not make sense.
Agreed.
A "download" involves a network transfer. Saving a file which already exists on disk, to another location, does not involve any network transfer (or if the browser does, it shouldn't). Given time I could actually browse the cache folder on my hard disk to locate and copy the file myself with my network cable disconnected... no download involved at all.

If the act of copying an already saved file to another location is called "download", then the description of "copy" or "save as" and "download" are exactly the same, which I know isn't true.
You need to log in before you can comment on or make changes to this bug.