Closed Bug 1770906 Opened 1 month ago Closed 10 days ago

Empty Email Subject: Let user choose if they want warnings

Categories

(Thunderbird :: Message Compose Window, enhancement)

Thunderbird 101
enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: jason.evangelho, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.64 Safari/537.36 Edg/101.0.1210.53

Steps to reproduce:

Wrote an email with empty Subject line.

Actual results:

When writing an email with an empty subject line, Thunderbird will always warn the user.

Expected results:

I've spoken to many users who appreciate the option to disable future warnings in the future. For example, when sending an email with an empty Subject line the first time, Thunderbird will display the warning, but should also display a checkbox allowing the user to disable future warnings. (e.g. "Don't warn me again")

I don't think that's a good idea.
I think empty subjects are a big nuisance. After all, it forces you to open these mails again and again to see what they were about.
For this reason, empty subjects were often used in spam messages, so that the recipients would actually open the mails and read them. This in turn led to spam filters preferentially sorting out such mails.
An empty subject also shows the sender in a bad light. It looks like he was too lazy to put some thought into the message.

It's not up to us to patronize the user, but in view of the negative consequences, I think the warning is quite appropriate.

Just my (1(1¢)

Without solid rationale in the request I'm inclined to agree with Alfred.

Requests that propose to change behavior should be backed by the user requesting it with solid rationale that really make the case for the change (use cases, business case, etc), especially when the change may result in painful behavior for others, in this case the receiver of an email without a subject line.

I agree with Alfred and Wayne. Sending with empty subject is not being a good net citizen.

Status: UNCONFIRMED → RESOLVED
Closed: 10 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.