Closed Bug 1771806 Opened 2 years ago Closed 2 years ago

Capture user input

Categories

(Toolkit :: Password Manager, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: serg, Assigned: emilio)

References

(Blocks 12 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

We should remember input.value that we observe in LoginManagerChild.jsm on change/input events.

By doing that we will be able to:

  • capture data that was entered by user and not by a script.
  • ignore irrelevant fields (hidden, display:none, opacity:0.001 or otherwise inaccessible to user) which should reduce number of bugs when we capture wrong field
  • gain some performance, because we will have smaller set of fields to operate on

Same approach should be used with Form Autofill.

Assignee: nobody → sgalich
Severity: -- → S3
Priority: -- → P2
Severity: S3 → N/A
Blocks: 1642570
Attached file WIP: Bug 1771806 - Capture user input (obsolete) —
Attachment #9282605 - Attachment is obsolete: true
Attachment #9282615 - Attachment description: WIP: Bug 1771806 - Record last interactive value in HTMLInputElement. → Bug 1771806 - Record last interactive value in TextControlState. r=smaug,masayuki
Blocks: 1765990
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f934958eed1b
Record last interactive value in TextControlState. r=masayuki
Regressions: 1776838
Regressions: 1776896
Assignee: sgalich → emilio
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Blocks: 578879
Blocks: 1783706
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: