Closed Bug 1771828 Opened 2 months ago Closed 1 month ago

Missing label/string to describe radiobox for default email address (title and/or tooltip)

Categories

(Thunderbird :: Address Book, defect, P1)

Thunderbird 102

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1776372

People

(Reporter: thomas8, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

(Keywords: ux-discovery)

Attachments

(2 files)

P1 because this needs strings.

No label, no tooltip: It's hard to tell for the user what the radio boxes are for.
Having a title label might be odd because of the limited space in the radio box column.
Maybe we could have a Default Email Address icon in the title?
At least (which might be sufficient), we should add a tooltip to the radio boxes, something like:

  • Set default email address

I'm also wondering if the meaning of Default Email Address needs a bit of explanation somewhere (speech bubble on column title icon?)

  • It's nor really a default but a preferred address.
  • Set title for some inputs, and remove the accessibility specials: the labels should not be hidden if used for accessibility, and just using normal semantics (title) will benefit all users
  • fix preferred checkbox to be radio and remove the vcard-email-primary-checkbox CustomEvent hack. No idea why that shows as a radio atm (?!)
  • selected is a boolean attribute in html: "true" is not valid
  • fix some elements that do not have optional closing tags
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED

It's not a default address, but a preferred one. With data from elsewhere, it can define the ordering.
We should fix the code to show the preferred address first, but I'm leaving that for another bug.

Blocks: tb102found
Summary: Missing string to describe radiobox for default email address (title and/or tooltip) → Missing label/string to describe radiobox for default email address (title and/or tooltip)
See Also: → 1776372

Marking this as duplicate of bug 1776372 since the work is being done there, and some other fixes in the patch have landed already.

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1776372
You need to log in before you can comment on or make changes to this bug.