Scattered text lines when using align=justify in RTL rendered pages.




Layout: Text
16 years ago
10 years ago


(Reporter: rmmmozilla, Assigned: smontagu)




Firefox Tracking Flags

(Not tracked)



(1 attachment)



16 years ago
This is evident in MAC OS and Windows platforms:
when a page is rendered Right to Left, as used by RTL tags, if a text block is
align justified, as a result - all lines of text within this block, are
scattered around, some aligned to the left, some centered and others aligned to
the right.
The result is very difficult to read.

To cause it one needs to use the following:
<div DIR = "RTL">
...... of the page
<div align= "justify">
Text comes here......
Text comes here......
Text comes here......
Text comes here......
</div> of the page


16 years ago
Severity: critical → normal


16 years ago
Component: DOM HTML → BiDi Hebrew & Arabic
reassign for real.
Assignee: jst → mkaply
QA Contact: stummala → zach

*** This bug has been marked as a duplicate of 146135 ***
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Can you provide a test case and screenshot? The HTML you describe doesn't show
the bug for me on Windows or Linux, but perhaps you have reduced it too far.

This may be a dupe of bug 121633, bug 131023, bug 148866, and/or Mac-specific
bug 146135.

Taking for now.
Resolution: DUPLICATE → ---

Comment 4

16 years ago
Assignee: mkaply → smontagu

Comment 5

16 years ago
Created attachment 104540 [details]
Hebrew alingned justify in a div tag. alignment out of order

It might be a duplicate bug report. I just couldn't locate it via Search.
attached is a sample screenshot.
code in use:
<div style="width:400px; text-align: justify">

Comment 6

16 years ago
Thanks for the screenshot. What is the URL of the page?

Comment 7

16 years ago
I can't leave the page like this, as it's a live forum page where visitors are
coming in, so I deleted this "justify" tag till the bug is fixed..
the change was temporarily made just for the screenshot.
The actual forum is at:

Comment 8

16 years ago
So do you think it is a dupe of one of the bugs mentioned in comment 3? I really
can't diagnose any further without at least a copy of the source that displays
the buggy behaviour.

Comment 9

16 years ago
It could be a duplicate, though in my case I don't use WORD nor see any relation
to any source - just plain justify code.
I rendered a dynamic PHP page for you, so you can have a look at the code in use
to trigger the bug:
This may help locate where problem occures within the DIV tag (note the straight
lines where lines are alinged diffrently; some do on the left side, some on the
right side - not BOTH - taking into account the 400px limit given in the DIV tag
(in this example).
Also note what happens if english AND hebrew words are mixed on the same line. I
have a wild guess that only then the line is jutified (block aligned on both sides).

Comment 10

16 years ago
The penny just dropped here: are you using Mozilla 1.0 (or 1.0.x)? Can you
retest with a current nightly?

I think this will turn out to be a dupe of a bug which has been fixed in the
trunk, but I don't yet know exactly which one.


Comment 11

16 years ago
Update: the bug was fixed between 1.2a and 1.2b.

Comment 12

16 years ago
Sorry, ignore my last two comments. This bug is not fixed in 1.2b, nor in the
latest nightlies, but it is fixed in my local tree, where I have applied
attachment 85955 [details] [diff] [review] from bug 74880.
Depends on: 74880

Comment 13

15 years ago returns a 404. Is there any other

Reporter, can you still reproduce this bug?


Comment 14

14 years ago
(In reply to comment #5)
> <div style="width:400px; text-align: justify">
> xxxxxx
> </div>

This code doesn't trigger anything similar to the bug in the screenshot
(attachment #104540 [details]). Since no testcase was provided, I'm closing this bug as


Last Resolved: 16 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 15

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl


10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.