Closed Bug 1772767 Opened 27 days ago Closed 17 days ago

[matrix] permanent 'Decrypting...' message if key for decryption is missing

Categories

(Thunderbird :: Instant Messaging, defect)

Thunderbird 102
defect

Tracking

(thunderbird102 fixed, thunderbird103 fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird102 --- fixed
thunderbird103 --- fixed

People

(Reporter: aryx, Assigned: freaktechnik)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Thunderbird 102.0a1 20220530 and 103.0a1 120220605 on Windows 8.1

After the credentials for one, different Matrix account got added to each of the two Thunderbird installations above, the tried to decrypt previous chat history and show "Decrypting..." for the 1:1 chat which persists.

There is a string in the application which is supposed to get used in such cases:
message.decryptionError=Could not decrypt the contents of this message. To request encryption keys from your other devices, right click this message.

If the patch for bug 1770459 works as it should, it will fix this.

there could actually be a missing Decrypting... -> Could not decrypt message path way. I'll have to check how exactly that state change happens.

Type: task → defect

(In reply to Martin Giger [:freaktechnik] from comment #2)

there could actually be a missing Decrypting... -> Could not decrypt message path way. I'll have to check how exactly that state change happens.

Okay, I think the path is exactly as it should be in the patch for bug 1770459 - sadly hard to reliably test.

See Also: → 1770459

Fixes a race where the message was not yet displayed but already queued for display, and the unread ruler (green line) being removed replacing the message with an older version of itself.

Assignee: nobody → martin
Status: NEW → ASSIGNED

Turns out this was not a bug specific to the Matrix code. At least the leftover cases I found after bug 1770459.

Component: Matrix → Instant Messaging
Product: Chat Core → Thunderbird
Version: trunk → Thunderbird 102
Target Milestone: --- → 103 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/6e20cb4bac84
Fix some edge cases where chat message replacement would fail. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 17 days ago
Resolution: --- → FIXED

Comment on attachment 9281441 [details]
Bug 1772767 - Fix some edge cases where chat message replacement would fail. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Some encrypted messages will never show up in their decrypted form or may regress back to their "Decrypting..." form
Testing completed (on c-c, etc.): Manually verified in Nightly.
Risk to taking this patch (and alternatives if risky): Low risk, changes edge case behavior.

Attachment #9281441 - Flags: approval-comm-beta?

Comment on attachment 9281441 [details]
Bug 1772767 - Fix some edge cases where chat message replacement would fail. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9281441 - Flags: approval-comm-beta? → approval-comm-beta+
Blocks: tb102found

I'm seeing this in 102.0. I don't see a way to request encryption keys. And worse, I intuitively double-click on the "Decrypting..." message and that causes the message to be deleted, so I can't see it from other devices either.

(In reply to Jason Dunsmore from comment #10)

I'm seeing this in 102.0. I don't see a way to request encryption keys. And worse, I intuitively double-click on the "Decrypting..." message and that causes the message to be deleted, so I can't see it from other devices either.

If there's no context menu action to request decryption keys this is probably a different bug. I haven't yet had a chance to track down an issue I'm aware of, where the decrypted message is never shown in a conversation that you've previously opened but isn't the currently active conversation.

Blocks: 1777713
You need to log in before you can comment on or make changes to this bug.