Closed Bug 1773144 Opened 6 months ago Closed 6 months ago

contacts API is broken after vCard changes

Categories

(Thunderbird :: Add-Ons: Extensions API, defect)

defect

Tracking

(thunderbird_esr102 fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr102 --- fixed

People

(Reporter: TbSync, Assigned: TbSync)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → john
Status: NEW → ASSIGNED
Attachment #9280127 - Attachment description: WIP: Bug 1773144 - Restore return values of contacts API. r=darktrojan → Bug 1773144 - Restore return values of contacts API. r=darktrojan
Attachment #9280127 - Attachment description: Bug 1773144 - Restore return values of contacts API. r=darktrojan → Bug 1773144 - Allow contacts API to handle properties again. r=darktrojan
Blocks: tb102found

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/3c089370f71c
Allow contacts API to handle properties again. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

Comment on attachment 9280127 [details]
Bug 1773144 - Allow contacts API to handle properties again. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
contacts API is broken

Testing completed (on c-c, etc.):
Tested by me and a few add-on developers.

Risk to taking this patch (and alternatives if risky):
Medium to low

Attachment #9280127 - Flags: approval-comm-beta?

Comment on attachment 9280127 [details]
Bug 1773144 - Allow contacts API to handle properties again. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9280127 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.