Closed Bug 1773249 Opened 2 months ago Closed 2 months ago

Dragging a contact onto the book it's already in causes the contact to be deleted

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(thunderbird102 fixed)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird102 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Somehow the "drop" event is firing even though it shouldn't, and that causes cards to be added to the destination book then deleted from the source book. If they're the same book then the card is deleted.

I think the cause is something to do with a "dragover" handler outside the address book browser, or maybe on the browser itself. That might be confusing the code into thinking there is a valid drop target when there isn't. It's hard to tell.

Assuming this affects 102. If not, please update the flags. Thanks

Version: unspecified → Thunderbird 102
Blocks: tb102found

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f64404889698
Prevent drop action on address book deleting the dropped card. r=thunderbird-reviewers,freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9280222 [details]
Bug 1773249 - Prevent drop action on address book deleting the dropped card. r=#thunderbird-reviewers

[Approval Request Comment]
Regression caused by (bug #): new AB
User impact if declined: (small) potential for data loss
Testing completed (on c-c, etc.): landed last week
Risk to taking this patch (and alternatives if risky): low

Attachment #9280222 - Flags: approval-comm-beta?

Comment on attachment 9280222 [details]
Bug 1773249 - Prevent drop action on address book deleting the dropped card. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9280222 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.