magical My Bugs query can coexist with a real query named "My Bugs"

RESOLVED DUPLICATE of bug 133173

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 133173
16 years ago
6 years ago

People

(Reporter: Steve VanSlyck, Assigned: Dawn Endico)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Bugzilla allows non-unique names for user's remembered queries. Suggest
requiring unique names.

Comment 1

16 years ago
If you try to remember a query with the same name as one already remembered,
both are saved in the footer, but only one can be run or deleted from the
dropdown box.

Steps to reproduce:
1. on http://bugzilla.mozilla.org/query.cgi, set up a query and select "Remember
this query and name it My Bugs", check "put in my page footer"
2. change the query and "Remember this query and name it My Bugs" AGAIN, check
"put in my page footer"
3. Observe "My Bugs  My Bugs" in footer.  Both can be run
4. "Forget my remembered query" for one of them (seems to be the second one that
gets forgotten)
5. Can't forget the other one, but it remains in the footer.

Expected results: the second one remembered should replace the first one.
|My Bugs| is a special case, ebcause the orignal query isn't really a stored entry.

The other queries will replace exisitng ones if they aalready exist
(Reporter)

Comment 3

16 years ago
But they don't. Just yesterday I was allowed to save separate queries under the
same name - and both names appeared in the page footer. I manually deleted the
one that was to have been replaced.
(Reporter)

Comment 4

16 years ago
Also - I was able to run both queries.

Comment 5

15 years ago
wfm, in fact the status message for this case wasn't good enough for me so i
just improved it.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

15 years ago
THis should not be WFM. Try to save a query with the name "My Bugs" - It will
not replace the default, which shows only a subset of someone's submitted bugs.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 7

15 years ago
My Bugs is not a query. It's a magical hack.
Summary: Disallow non-unique names for remembered queries. → magical My Bugs query can coexist with a real query named "My Bugs"

Comment 8

15 years ago
Created attachment 124186 [details] [diff] [review]
make My Bugs behave like a normal query

Updated

15 years ago
Attachment #124186 - Flags: review?(justdave)

*** This bug has been marked as a duplicate of 133173 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Comment on attachment 124186 [details] [diff] [review]
make My Bugs behave like a normal query

the idea presented on bug 133173 may be a better way to do this, but nobody's
written a patch to do it yet...
Attachment #124186 - Flags: review?(justdave)
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.