Closed Bug 1773568 Opened 2 years ago Closed 2 years ago

Add-on incompatibility notification not displayed due to missing string details-notification-incompatible-link from aboutAddons.ftl

Categories

(Toolkit :: Add-ons Manager, defect, P3)

Firefox 102
defect

Tracking

()

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr102 + ---
firefox103 --- fixed

People

(Reporter: rachel, Assigned: TbSync)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

In our Thunderbird fork we see error console messages from here
https://searchfox.org/mozilla-central/rev/552bfc6334b797d92fb2ce8e93a6ace5f47cd56d/intl/l10n/Localization.h#54
complaining about the missing string details-notification-incompatible-link.
It should be added here:
https://searchfox.org/mozilla-central/rev/552bfc6334b797d92fb2ce8e93a6ace5f47cd56d/toolkit/locales/en-US/toolkit/about/aboutAddons.ftl#497

We did so via
https://github.com/Betterbird/thunderbird-patches/blob/main/102/misc/07-misc-details-notification-incompatible-link-m-c.patch
and the result is that the incompatible link now shows as in the attached image.

You might want to fix the issue in Toolkit.

Strings were migrated in bug 1507471 but it looks like there wasn't previously a string for notification.incompatible.link, unlike the others

See Also: → 1507471
Assignee: nobody → john
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Blocks: tb102found
Summary: details-notification-incompatible-link string missing from aboutAddons.ftl → Add-on incompatibility notification not displayed due to missing string details-notification-incompatible-link from aboutAddons.ftl
Severity: -- → S3
Priority: -- → P3
Pushed by john.bieling@gmx.de:
https://hg.mozilla.org/integration/autoland/rev/0c159333dee2
Add missing details-notification-incompatible-link string to aboutAddons.ftl. r=eemeli
Blocks: 1775093
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: