Closed Bug 1774514 Opened 3 months ago Closed 3 months ago

Use the same font sizes in preferences pages and dialogs, and make it relative to the usual font size

Categories

(Thunderbird :: Mail Window Front End, enhancement)

enhancement

Tracking

(thunderbird_esr102 fixed, thunderbird102+ affected)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr102 --- fixed
thunderbird102 + affected

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(5 files)

Currently in the Settings, Account Settings, and Add-On Manager pages, the font size used is the same (about 15px) regardless of the standard font size used by the OS. This makes the text on these pages much larger than the text in the rest of the UI on Windows and macOS.

In this bug I'll change the font size on these pages so that they relate to the standard font size.

Summary: Use sane font sizes in preferences pages → Use the same font sizes in preferences pages and dialogs, and make it relative to the usual font size

This patch sets the base font-size of all of the settings pages and dialogs in one place, and makes it 110% of the message-box size.

Not only Windows/Mac. The fonts are pretty large on linux as well, at least for me. Thanks for fixing!

I'm going to ship this then come back and attack the inconsistent first column on all these pages.

Keywords: leave-open
Target Milestone: --- → 103 Branch
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/bc2fe4a50e0f
Use the same font sizes in preferences pages and dialogs, and make it relative to the usual font size. r=aleca

Comment on attachment 9281551 [details]
Bug 1774514 - Use the same font sizes in preferences pages and dialogs, and make it relative to the usual font size. r=aleca

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: fonts in settings pages are really out of scale with the rest of the UI
Testing completed (on c-c, etc.): landed today
Risk to taking this patch (and alternatives if risky):

Attachment #9281551 - Flags: approval-comm-beta?

Comment on attachment 9281551 [details]
Bug 1774514 - Use the same font sizes in preferences pages and dialogs, and make it relative to the usual font size. r=aleca

[Triage Comment]
Approved for beta

Attachment #9281551 - Flags: approval-comm-beta? → approval-comm-beta+

Is it expected that the font sizes in the preferences are now much smaller on macOS, compared to Firefox? Since you're following the preferences design of Firefox it's a bit surprising to have such a noticeable difference in font size (and to be honest I think it's at least one pixel to small, it's really tiny now -- at least for me as someone who has not the best eyes in the world).

(In reply to Sören Hentzschel from comment #8)

Is it expected that the font sizes in the preferences are now much smaller on macOS, compared to Firefox? Since you're following the preferences design of Firefox it's a bit surprising to have such a noticeable difference in font size (and to be honest I think it's at least one pixel to small, it's really tiny now -- at least for me as someone who has not the best eyes in the world).

Yes. We've already broken away from the Firefox theme in a number of ways and this is just another. The font size should be slightly bigger than the main mail tab, is that not too small also? FWIW we now have an option to change the font size across the whole interface, which didn't (really) work on some of the pages changed here.

The font size should be slightly bigger than the main mail tab, is that not too small also?

True. In my perception the tab label is larger but the inspector proves that it's even smaller. 😅 But the truth is also that tabs have such a small surface that there is not much to read. And I know what the tab label of the main mail tab or of an opened e-mail says. In the preferences interface I actively search for an option. With so much text content it's more pleasant to have a bit larger font size.

FWIW we now have an option to change the font size across the whole interface, which didn't (really) work on some of the pages changed here.

That's good to know. Thanks.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/afb3bb8bf928
Consistently style the sidebars on preferences pages. r=aleca

Comment on attachment 9281986 [details]
Bug 1774514 - Consistently style the sidebars on preferences pages. r=aleca

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

Attachment #9281986 - Flags: approval-comm-beta?

Comment on attachment 9281986 [details]
Bug 1774514 - Consistently style the sidebars on preferences pages. r=aleca

[Triage Comment]
Approved for beta

It's a lot of change, but let's take it and explicitly QA as soon as it lands to make sure there are no ill effects.

Flags: needinfo?(bugzilla2007)
Attachment #9281986 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/34f23ec4e2e8
Set the button/menulist/input size font size dependent. r=aleca
https://hg.mozilla.org/comm-central/rev/b824bb536b46
Override the common.css to let us style the dialog-button-box buttons. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

(In reply to Pulsebot from comment #17)

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/34f23ec4e2e8
Set the button/menulist/input size font size dependent. r=aleca
https://hg.mozilla.org/comm-central/rev/b824bb536b46
Override the common.css to let us style the dialog-button-box buttons. r=aleca

You want these also on esr102?

Flags: needinfo?(richard.marti)

Comment on attachment 9281986 [details]
Bug 1774514 - Consistently style the sidebars on preferences pages. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9281986 - Flags: approval-comm-beta+ → approval-comm-esr102+

Comment on attachment 9281854 [details]
Bug 1774514 - Set the button/menulist/input size font size dependent. r=aleca

[Approval Request Comment]
User impact if declined: buttons on in-content pages too tall
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Flags: needinfo?(richard.marti)
Attachment #9281854 - Flags: approval-comm-beta?

Comment on attachment 9281855 [details]
Bug 1774514 - Override the common.css to let us style the dialog-button-box buttons. r=aleca

[Approval Request Comment]
User impact if declined: some buttons use the m-c styling instead of our one
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9281855 - Flags: approval-comm-beta?
Attachment #9281854 - Flags: approval-comm-esr102?
Attachment #9281855 - Flags: approval-comm-esr102?

Comment on attachment 9281855 [details]
Bug 1774514 - Override the common.css to let us style the dialog-button-box buttons. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9281855 - Flags: approval-comm-esr102?
Attachment #9281855 - Flags: approval-comm-esr102+
Attachment #9281855 - Flags: approval-comm-beta?

Comment on attachment 9281854 [details]
Bug 1774514 - Set the button/menulist/input size font size dependent. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9281854 - Flags: approval-comm-esr102?
Attachment #9281854 - Flags: approval-comm-esr102+
Attachment #9281854 - Flags: approval-comm-beta?

(In reply to Wayne Mery (:wsmwk) from comment #19)

Comment on attachment 9281986 [details]
Bug 1774514 - Consistently style the sidebars on preferences pages. r=aleca

[Triage Comment]
Approved for esr102

yes

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/3294a01d24a9
Use the variable for the spinbutton height calculation. r=aleca

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED

Comment on attachment 9282551 [details]
Bug 1774514 - Use the variable for the spinbutton height calculation. r=aleca

[Approval Request Comment]
User impact if declined: spin buttons in in-content pages don't use the full height they could
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9282551 - Flags: approval-comm-esr102?

Comment on attachment 9282551 [details]
Bug 1774514 - Use the variable for the spinbutton height calculation. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9282551 - Flags: approval-comm-esr102? → approval-comm-esr102+

(In reply to Wayne Mery (:wsmwk) from comment #16)

Comment on attachment 9281986 [details]
Bug 1774514 - Consistently style the sidebars on preferences pages. r=aleca
It's a lot of change, but let's take it and explicitly QA as soon as it lands to make sure there are no ill effects.

Looks good overall - great job, much better than before. In the future, things like this would probably require acceptance criteria defined before QA testing. Sorry for having missed this at the time, was busy with more urgent QA on the new AB.

Nits:

  • As mentioned in patch discussion, we definitely need a max-width for Account Settings sidebar (or a min-width on the content side) so that it won't break on pathologically long account names as it does now (content pane not accessible).
  • Also, it would be great if auto-width calculation would figure in the OS-dependent vertical scrollbar width - with more accounts and only slightly longer account names, the last few characters are still clipped and replaced with ... which doesn't really make sense for auto-adjust.

Richard, would you be able to look into these nits here, or do we need a new bug?

Flags: needinfo?(bugzilla2007) → needinfo?(richard.marti)

The problem is the tree for the many sub pages in the Account manager. Alex planned to overhaul this area but when this happens is out of my knowledge. I don't know if there exists a bug for this already.

This bug here shouldn't be used for new things as it is closed since some months.

Flags: needinfo?(richard.marti)
You need to log in before you can comment on or make changes to this bug.