Closed Bug 1775292 Opened 2 months ago Closed 2 months ago

For hostname of LDAP AB, cannot use IPv6 address literals, only hostnames or IPv4 address literals

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 90
defect
Not set
normal

Tracking

(thunderbird_esr91 wontfix, thunderbird_esr102 fixed, thunderbird102 affected)

RESOLVED FIXED
103 Branch
Tracking Status
thunderbird_esr91 --- wontfix
thunderbird_esr102 --- fixed
thunderbird102 --- affected

People

(Reporter: thomas8, Assigned: rnons)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1225783 +++
Copying this over from the other bug so that we can close that.
From Bug 1225783 Comment 2.

Steps to reproduce:

  1. Set up an dual-stack LDAP server.
  2. Configure address search using this LDAP server.

Actual result:

It's not possible to configure literal IPv6 address of an LDAP server. Without any error, the config reverts to previously entered value. Enclosing IPv6 literal inside brackets results in invalid address error.

Expected result:

Allow configuring literal IPv6 address of an LDAP server.

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 103 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d898cff00d15
Support using ipv6 address as ldap hostname. r=benc

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Amazing - so after 7 years on record we're able to fix this bug within a day after it's refiled cleanly! That's great teamwork between QA and devs! We have more such bugs, should try this more often...

Comment on attachment 9282313 [details]
Bug 1775292 - Support using ipv6 address as ldap hostname. r=benc

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Cannot use ipv6 address as ldap host name
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9282313 - Flags: approval-comm-esr102?

Comment on attachment 9282313 [details]
Bug 1775292 - Support using ipv6 address as ldap hostname. r=benc

[Triage Comment]
Approved for esr102

Attachment #9282313 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.