Closed Bug 1775366 Opened 5 months ago Closed 2 months ago

Remove dead telemetry/healthreport tests and other references to advancedPrefs

Categories

(Firefox :: Settings UI, task, P5)

Desktop
All
task

Tracking

()

RESOLVED FIXED
107 Branch
Tracking Status
firefox103 --- wontfix
firefox107 --- fixed

People

(Reporter: Gijs, Assigned: dwalker, Mentored)

References

Details

(Keywords: good-first-bug, Whiteboard: [lang=css])

Attachments

(1 file)

While reviewing https://phabricator.services.mozilla.com/D149665 I looked for 'advanced' in preferences code.

This found me this set of things:

https://searchfox.org/mozilla-central/search?q=advancedPrefs

There's some CSS and 2 telemetry-related tests.

In bug 1075055 we added some test(s) for telemetry and/or healthreport.

In bug 1545552 we noticed that it wasn't running. But we kept a skip-if test in the manifest that checks if telemetry is true. But from a quick look at a random log file, telemetry is false anyway:

[task 2022-06-21T22:12:25.759Z] 22:12:25     INFO -     telemetry: False

this makes sense (don't want test jobs sending telemetry), and anyway, AFAICT both browser_telemetry.js and browser_healthreport.js have been broken a while (they time out if run locally), because the advancedPrefs element which both rely on per the searchfox query above has not existed for a while now.

Dexter, unless you object, I'd like to suggest removing all of this.

Flags: needinfo?(alessio.placitelli)

(In reply to :Gijs (he/him) from comment #0)

Dexter, unless you object, I'd like to suggest removing all of this.

No objection, but let's ask :chutten to make sure.

Flags: needinfo?(alessio.placitelli) → needinfo?(chutten)

Yeah, I can confirm that there's nothing in Telemetry that should be troubled by this removal.

Flags: needinfo?(chutten)

To fix this bug we need to remove the two test files linked in https://searchfox.org/mozilla-central/search?q=advancedPrefs (using hg remove or the git equivalent), and their references from the browser.ini file in the same directory. And we'll want to remove the CSS rule that also shows up in those search results.

Mentor: gijskruitbosch+bugs
Severity: -- → N/A
Keywords: good-first-bug
Priority: -- → P5
Whiteboard: [lang=css]
Assignee: nobody → dj
Status: NEW → ASSIGNED
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7cc8c4395eb1
remove unused style rule (advancedPrefs). r=mstriemer,preferences-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
You need to log in before you can comment on or make changes to this bug.