Closed Bug 1776613 Opened 2 months ago Closed 28 days ago

Error “Encountered a corrupt folder” appear when you try to start Thunderbird version 102.0b8. 102.0b7 was OK.

Categories

(Thunderbird :: Folder and Message Lists, defect, P1)

Thunderbird 102

Tracking

(thunderbird_esr102+ affected, thunderbird102 wontfix, thunderbird103 affected)

RESOLVED INVALID
Tracking Status
thunderbird_esr102 + affected
thunderbird102 --- wontfix
thunderbird103 --- affected

People

(Reporter: tentiuzyou, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [add-on:QuickFolders])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36 OPR/88.0.4412.40

Steps to reproduce:

Error messages “Encountered a corrupt folder” appear when you try to start Thunderbird (version 102.0b8 64bit Windows11Pro). This error occurs on Draft folder in every account of Thunderbird. You will see these errors only when you use IMAP protocol.
Thank you for your attention.

Actual results:

Error messages “Encountered a corrupt folder” appear

Expected results:

no Error Message appears

Group: mail-core-security

I have installed the official Thunderbird 102 (Windows11 Pro 64bit JPN). This bug has not been fixed.
Thank you.

Blocks: tb102found

Also reported at https://support.mozilla.org/en-US/questions/1381312#answer-1515750

  1. That's not you, correct?
  2. Who is your mail provider?
Flags: needinfo?(tentiuzyou)

Gene,
I'm not finding "Encountered a corrupt folder" in searchfox. What do you think this is about?

Flags: needinfo?(gds)

I can't find it or anything similar either. Is this maybe a translation back to english from another locale string?

Flags: needinfo?(gds)

Does the reporter really only see this for Draft folders and all other folders are OK?
Maybe reporter needs to check to be sure the setting under Copies and Folders"/"Drafts and Templates" are set to the correct folder.
Which previous TB version was the reporter using that worked OK for Drafts?

(In reply to Wayne Mery (:wsmwk) from comment #2)

Also reported at https://support.mozilla.org/en-US/questions/1381312#answer-1515750

  1. That's not you, correct?

This is not me.

  1. Who is your mail provider?

My Email providers are Mainly Gmails and Japanese service provideder FC2.

Flags: needinfo?(tentiuzyou)

(In reply to gene smith from comment #5)

Does the reporter really only see this for Draft folders and all other folders are OK?
Maybe reporter needs to check to be sure the setting under Copies and Folders"/"Drafts and Templates" are set to the correct folder.

I am using Thunderbird as Default.
I do not NO how to check the Setting.

Which previous TB version was the reporter using that worked OK for Drafts?

Thunderbird (version 102.0b7 64bit Windows11Pro JPN) was OK.

Do you only see the error message for Draft folders and all other folders are OK?

(In reply to gene smith from comment #8)

Do you only see the error message for Draft folders and all other folders are OK?

Yes. in deed.
Only for Draft folders.

Thank you.

I do not NO how to check the Setting.

Right-click on the account name for your server on the main screen: Gmail or FC2
Then click "Copies and Folders" for the account
Then on the page that appears, look for "Drafts and Templates" near the bottom
Make sure a valid folder is selected for Drafts, either,
() Drafts folder on [your Gmail or FC2, depending on which account you are setting] (This is probably default)
() Other: [Only if you want drafts to be somewhere else]

Make sure all accounts have a valid setting for where Drafts are put.

If this looks OK meaning Drafts are set to go to the appropriate folder and you still see the error when you click on Drafts, you might try to "Repair" the Drafts folder:

Right-click on Drafts folder for the Gmail or FC2 account
Click "Properties" from the menu that appears.
On the screen that appears, click "Repair Folder" button to "repair" the folder.

Do this "repair" for Drafts folders on all accounts.

If the problem persists after doing the above item, I would suggest that you record and attach an IMAP:5 log file as explained here: https://wiki.mozilla.org/MailNews:Logging

Confirming based on multiple reports. But the cause is still to be determined.

Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(benc)
Priority: -- → P1
Summary: Error messages “Encountered a corrupt folder” appear when you try to start Thunderbird (version 102.0b8). → Error “Encountered a corrupt folder” appear when you try to start Thunderbird version 102.0b8. 102.0b7 was OK.

Right-click on the account name for your server on the main screen: Gmail or FC2
Then click "Copies and Folders" for the account

I could not find “Copies and Folders” even after right-clicking on the account name for my server on the main screen: Gmail or FC2.

Right-click on Drafts folder for the Gmail or FC2 account
Click "Properties" from the menu that appears.
On the screen that appears, click "Repair Folder" button to "repair" the folder.
Do this "repair" for Drafts folders on all accounts.

The resolution above did not work for this issue.
The same error messages were still displayed.

Thank you for your kind support.

Sorry, I left out a step (now in dark/bold font):

Right-click on the account name for your server on the main screen: Gmail or FC2
Click on "Settings"
Then click "Copies and Folders" for the account
Then on the page that appears, look for "Drafts and Templates" near the bottom
Make sure a valid folder is selected for Drafts, either,
() Drafts folder on [your Gmail or FC2, depending on which account you are setting] (This is probably default)
() Other: [Only if you want drafts to be somewhere else]

(In reply to gene smith from comment #13)

Sorry, I left out a step (now in dark/bold font):

Right-click on the account name for your server on the main screen: Gmail or FC2
Click on "Settings"
Then click "Copies and Folders" for the account
Then on the page that appears, look for "Drafts and Templates" near the bottom
Make sure a valid folder is selected for Drafts, either,
() Drafts folder on [your Gmail or FC2, depending on which account you are setting] (This is probably default)
() Other: [Only if you want drafts to be somewhere else]

Thank you for your advice.
I will try it immediately.

(In reply to gene smith from comment #13)

Sorry, I left out a step (now in dark/bold font):

Right-click on the account name for your server on the main screen: Gmail or FC2
Click on "Settings"

Thank you for your advice. I understood what you have said when I changed my language setting from Japanese to English.

(1) I usually have been setting "Draft" as "Default". But some accounts have been set "Draft" as "Others" from the beginning, and I can not change the setting even when I change the value from "Others" to "Default". Some accounts refused me to change the setting, simply bouncing back to "Others" when Thunderbird was rebooted. And I see the same error message again and again.

(2) Some of my accounts in Thunderbird come to display no error message any longer although I did not do anything. I do not know why but some accounts come to work appropriately by now.

(3) Some of Gmail accounts come to work properly after rebooting Thunderbird some times. FC2 account and some Gmail acccounts still display errors no matter whether "Draft" is set as "Default" or "Others". I also checked some good accounts, but I found some have "Draft" as "Default" and some have "Draft" as "Others".

(4) Finally, I found an addon "QuickFolders", and turned it off. Then I have not seen the error message any more. Even after turning off the addon, I still can not change the value of "Draft" setting.

I am deeply thankful for your advice and to the members of this community.

I discussed this with Ben and this may a dupe of one of the existing folder cache issues.

Flags: needinfo?(benc)
See Also: → 1778888

If you do get this, please take a screenshot of the error dialog.

(In reply to Magnus Melin [:mkmelin] from comment #17)

If you do get this, please take a screenshot of the error dialog.

I am sorry but could you tell me Hou to attach a screenshot.

(In reply to Rei Narumiya from comment #18)

(In reply to Magnus Melin [:mkmelin] from comment #17)

If you do get this, please take a screenshot of the error dialog.

I am sorry but could you tell me Hou to attach a screenshot.

https://support.mozilla.org/en-US/kb/how-to-make-screenshots

Attached image snap001696.jpg

I have the screenshot which I took when I saw the issue for the first time. Many little warning windows appeared on the screen. This screenshot is one of those windows.

Not sure if the error is coming from gmail or FC2 server or is it produced by TB? We don't have string "Encountered a corrupt folder" in the released TB code so maybe it's a localized translation. But why back to English?
Rei, what version of TB are you running and in which language? Japanese I assume? Where did you get the thunderbird program?
I don't know where to find the archive of the translated English strings for a Japanese TB version. (This is something I know nothing about.)

Also, Rei wrote in comment 15:

(4) Finally, I found an addon "QuickFolders", and turned it off. Then I have not seen the error message any more. Even after turning off the addon, I still can not change the value of "Draft" setting.

Not sure if this means the problem is actually resolved.
Maybe you don't need to change the value of the Drafts setting if it is now working OK? Can you save messages you are writing to Drafts folder?

Thanks, that message must be coming from the QuickFolders add-on.

Whiteboard: [add-on:QuickFolders]

(In reply to Magnus Melin [:mkmelin] from comment #22)

Thanks, that message must be coming from the QuickFolders add-on.

I don't think the actual message is generated by my Add-on QuickFolders, I normally use the term "invalid folder" not "corrupt folder" - this can be caused by an invalid / changed server URI. Maybe it tries to access the folder but the message must come from Thunderbird itself.

"Corrupt Folder" - I do not use this term because it implies that I would know a folder was actually corrupted. My Add-on would avoid such a term - it only points to folders (and uses their URIs for navigation and moving emails).

The internal folders URIs possibly changed during update to Thunderbird 102 - see bug 1573690, which may lead to "invalid tabs" - I added some code to deal with this - issue 281

(In reply to gene smith from comment #21)

(In reply to gene smith from comment #21)

https://www.thunderbird.net/en-US/thunderbird/all/

BETA CHANNEL DL TB102.0b2 Automatically Update(JPN 64B)

This image Thunderbird version 102.0b8.JPN Automatically Update
I am glad to know that this problem is caused by Quick Folders add-on.

Thank you very much for your kind reply.

(In reply to Magnus Melin [:mkmelin] from comment #22)

Thanks, that message must be coming from the QuickFolders add-on.

Thank you very much.

(In reply to Rei Narumiya from comment #25)

(In reply to Magnus Melin [:mkmelin] from comment #22)

Thanks, that message must be coming from the QuickFolders add-on.

Thank you very much.

Well Axel (QuickFolder developer I think) in comment 23 says it's not coming from QuickFolders. So still a mystery.
Rei, maybe you have other add-ons in addition to QuickFolders that may produce this message?

FWIW, I searched again under https://searchfox.org/l10n/source/ and don't find "Encountered a corrupt folder" or anything similar. Not sure if that's the correct place to look to find strings for releases in all languages.

I'm not sure what's going on here, but what we do know is that the message isn't coming from Thunderbird itself.
Since we don't have information indicating Thunderbird could be doing something wrong, I'm going to close this.

Status: NEW → RESOLVED
Closed: 28 days ago
Resolution: --- → INVALID

(In reply to gene smith from comment #26)

(In reply to Rei Narumiya from comment #25)

(In reply to Magnus Melin [:mkmelin] from comment #22)

Thanks, that message must be coming from the QuickFolders add-on.

Thank you very much.

Well Axel (QuickFolder developer I think) in comment 23 says it's not coming from QuickFolders. So still a mystery.
Rei, maybe you have other add-ons in addition to QuickFolders that may produce this message?

I am sorry for my late reply.
I've searched a lot since then, but I couldn't find an add-on that gives such a message. If there is anything, I will report it again.

(In reply to Magnus Melin [:mkmelin] from comment #27)

I'm not sure what's going on here, but what we do know is that the message isn't coming from Thunderbird itself.
Since we don't have information indicating Thunderbird could be doing something wrong, I'm going to close this.

I understand. No more writes to this thread. Thank you.

You need to log in before you can comment on or make changes to this bug.