normalize column names and make them consistent with those reflected externally in RDF

RESOLVED DUPLICATE of bug 200837

Status

()

Bugzilla
Database
--
enhancement
RESOLVED DUPLICATE of bug 200837
16 years ago
6 years ago

People

(Reporter: myk, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
The Bugzilla database schema is full of redundant names like
"bugs.bug_severity".  These should be normalized (i.e. "bugs.bug_severity" ->
"bugs.severity"), and the resulting names made consistent with those reflected
externally in RDF files (f.e. buglist.cgi's and duplicates.cgi's RDF outputs).
We could do this - but it would be a really big hassle, and the question has to
be: is it worth it?

It would make old XML (RDF, Bugzilla exports) incompatible with new, would break
bookmarks, stored queries, columnlist cookies, and loads of other places where
the column name is considered the canonical way of referring to a field. There
would be a shedload of migration code to write, and we'd have to have
backwards-compatibility hacks in lots of places. We'd also have to change a load
of code in Bugzilla which uses the current names.

Some of the inconsistencies are irritating - but are they irritating enough to
be worth all this hassle?

Gerv
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → general
QA Contact: mattyt-bugzilla → default-qa

Comment 3

6 years ago
My vote to mark this bug as wontfix, for the reason gerv gave in comment 1.
Assignee: general → database
Severity: normal → enhancement
Component: Bugzilla-General → Database

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 200837
You need to log in before you can comment on or make changes to this bug.