When replying, text attachments are quoted with the original message

RESOLVED DUPLICATE of bug 161775

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 161775
15 years ago
9 years ago

People

(Reporter: Pavel Andreev, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
Future
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

As a support engineer, I often receive messages with huge text attachments. I am
not a Mozilla guru and I have found no way to not quote these attachments when
replying. 

Reproducible: Always

Steps to Reproduce:
1. Create a one-megabyte text file, trace.txt
2. Send yourself a short message and attach trace.txt to it
3. Receive the message and hit Reply
4. Delete quoted contents of trace.txt and answer the remaining short message

Actual Results:  
With my 600Mhz P3, it takes about 30 seconds of 100% CPU utilization to generate
the reply, then I select all the lines of the quoted attachments by hitting
Shift-Ctrl-End and it takes another 30 seconds to delete them.

Expected Results:  
I would like Mozilla not to quote any attachments when replying. The behavior
could be user-configurable, with choices like "Always quote", "Never quote",
"Ask" or "Ask if the attachment is larger than xxx"
(Assignee)

Comment 1

15 years ago
Mozilla automatically display inline attachment event their are specified not to
be. I think it's ok when displaying the message but when replying, we should
repect the content-disposition header of the attachment. That will prevent
quoting  real attachment.
Severity: normal → enhancement
Target Milestone: --- → Future

Comment 2

15 years ago
Confirming bug and agreeing with reporter's suggestion.  :-)
Status: UNCONFIRMED → NEW
Ever confirmed: true
see also http://bugzilla.mozilla.org/show_bug.cgi?id=161775

what's new about this ?

Comment 4

14 years ago
*** Bug 244425 has been marked as a duplicate of this bug. ***
Product: MailNews → Core

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 161775 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.