<span>, &nbsp; and bidi results in incorrect line break

RESOLVED DUPLICATE of bug 282760

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 282760
15 years ago
10 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: smontagu)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
See:
http://www.hixie.ch/tests/adhoc/css/text/white-space/normal/line-breaking/bidi/003.html

There is a line of &nbsp; characters mixed in with RLO, LRO, and PDFs. The
result should be that the overrides have no effect on the rendering. All is well
until an unstyled <span> is introduced to the mix, where suddenly the line
breaks at another position.

Updated

15 years ago
Depends on: 206152

Updated

15 years ago
Blocks: 206152
No longer depends on: 206152
Bug 282760 was actually a duplicate of this bug, and the fix to that bug fixes
this testcase as well (verified by comparing a 20050620 build to a 20050621 build).

When verifying this, plese remember to install the Ahem font (from
http://www.hixie.ch/resources/fonts/) and restart Firefox before viewing the
statcase.

*** This bug has been marked as a duplicate of 282760 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.