Closed Bug 1777483 Opened 3 months ago Closed 2 months ago

Implement Extension button context menu (formerly "submenu")

Categories

(WebExtensions :: General, enhancement, P2)

enhancement

Tracking

(firefox105 fixed)

RESOLVED FIXED
105 Branch
Tracking Status
firefox105 --- fixed

People

(Reporter: zombie, Assigned: willdurand)

References

(Depends on 1 open bug, Blocks 3 open bugs)

Details

(Whiteboard: [addons-jira])

Attachments

(4 files, 1 obsolete file)

Clicking the submenu button replaces the panel

  • submenu has same items as right-click menu on the browser action
  • except that [Pin to Overflow] is [Pin to toolbar]
  • and items unrelated to extensions like [Menu bar] or [Customize]
Depends on: 1777481
Whiteboard: [addons-jira]
Severity: -- → N/A
Priority: -- → P2
Blocks: 1778682
Blocks: 1778684
Assignee: nobody → wdurand
No longer blocks: 1778684
Attachment #9285457 - Attachment is obsolete: true
Summary: Implement Extension button submenu → Implement Extension button context menu (formerly "submenu")

(In reply to Tomislav Jovanovic :zombie from comment #0)

Clicking the submenu button replaces the panel

  • submenu has same items as right-click menu on the browser action
  • except that [Pin to Overflow] is [Pin to toolbar]
  • and items unrelated to extensions like [Menu bar] or [Customize]

We are going to implement this without a submenu/subview. Instead, we'll use a context menu that we can open using the "gear" icon.

Blocks: 1780746

While working on this bug, I noticed a problem with the context menu disappearing (in part) behind the panel. Looks like it's a known bug.

Depends on: 1763990

I am going to submit multiple patches to ease with the reviews. Here is how I plan to fix this bug (roughly):

  1. add a new context menu for extensions in the unified extensions panel. It should be attached on the "cog"/"gear" button
  2. add extension actions to the context menu introduced in (1)
  3. add primary button support to open the context menu

The last piece would be:

except that [Pin to Overflow] is [Pin to toolbar]

which I am probably going to defer into a different bug as it kinda depends on Bug 1777489.

I only added two test cases to cover the integration between the new
context menu and the existing logic for the actions/origin controls
(both have their own tests).

Depends on D152665

Attachment #9287201 - Attachment description: WIP: Bug 1777483 - Part 3 - Open context menu when clicking the menu button. → Bug 1777483 - Part 3 - Open context menu when clicking the menu button. r?mixedpuppy!
Attachment #9287053 - Attachment description: Bug 1777483 - Part 2 - Add extension actions and origin controls to the unified extensions context menu. r?rpl! → Bug 1777483 - Part 2 - Add origin controls to the unified extensions context menu. r?rpl!
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/920759291618
Part 1 - Add a new context menu for extensions in the unified extensions panel.  r=mixedpuppy,desktop-theme-reviewers
https://hg.mozilla.org/integration/autoland/rev/9e6bb708b6c0
Part 2 - Add origin controls to the unified extensions context menu. r=rpl
https://hg.mozilla.org/integration/autoland/rev/baf27e2f44d6
Part 3 - Open context menu when clicking the menu button.  r=mixedpuppy
Regressions: 1782138

Oops, I forgot to add the leave-open keyword. I have one more patch to attach to this bug so I am going to change the status again. Sorry for the noise!

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 105 Branch → ---
Attachment #9287526 - Attachment description: WIP: Bug 1777483 - Part 4 - Add extension actions to the unified extensions context menu. r?rpl! → Bug 1777483 - Part 4 - Add extension actions to the unified extensions context menu. r?rpl!
Blocks: 1782203
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ab1acf1b981
Part 4 - Add extension actions to the unified extensions context menu. r=rpl
Regressions: 1782304
Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
Blocks: 1782456
You need to log in before you can comment on or make changes to this bug.