Closed Bug 1777731 Opened 2 months ago Closed 1 month ago

After Tbird 102 Update, Mail filters are screwed up. "folder xxxx not found...so the filter(s) associated with this folder will be disabled"

Categories

(Thunderbird :: Filters, defect, P2)

Thunderbird 102

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1773822

People

(Reporter: freedos.la, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image TBirdFuckup1.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:101.0) Gecko/20100101 Firefox/101.0

Steps to reproduce:

Just trying to run filters that have been running fine until minutes before the update to Thunderbird 102

Actual results:

After the update, I noticed a lot of unread, new messages in the inbox of several email accounts. All of those messages (from 3-4 to several dozens, depending on the account) should have been moved into appropriate sub folders, just as they were just fine up until the 102 update was applied and Tbird needed to be restarted.
When trying to manually initiate a run of the filters on that folder (inbox), error messages started to pop up about the filter not being applied as allegedly, the target folder into which the message(s) was supposed to be moved would not exist and thus the rule would be disabled. That happened despite the folder clearly existing and I am able to either a) move the message via drag&drop into that folder or b) edit or recreate the rule and browsing and select the intended target folder. I attached a screenshot which shows the top of the inbox of of the accounts as well as the error message as well the clearly existing folder in the folder pane.

Expected results:

Previously existing filters should just continue to run. With dozens of rules on each account, I should not have to go each and every rule to verify and edit or recreate those filters!

Might be from bug 1573690 / bug 1483485 which may have caused the folder URIs to change. Not marking those as regression though because this is speculative

See Also: → 1573690

I hate to be the guy creating "me too" comment, but I'm having exactly the same issue.

  • Selecting filters and running them manually works correctly
  • The filter logs does not indicate any failure on interrupted processing.

(In reply to Olivier Jaquemet from comment #2)

I hate to be the guy creating "me too" comment, but I'm having exactly the same issue.

  • Selecting filters and running them manually works correctly
  • The filter logs does not indicate any failure on interrupted processing.

Well, that is a little bit different then in my case. Manually running a filter that should have run automatically upon receiving an email did NOT work in my case, unless I first edited the rule to set the target folder for the move, again. Or recreated a rule from scratch.

I may have re-edited some filters in search for the problem, leading some of them to work.... Not sure...
@thunderbird developpers, I can provide any relevant data if it can help.

Priority: -- → P2

Thanks for reporting. It's helpful if you can provide the msgFilterRules.dat, this is a copy of mine

version="9"
logging="no"
name="test"
enabled="yes"
type="17"
action="Move to folder"
actionValue="imap://rnons@imap.localhost/INBOX"
condition="AND (subject,contains,read)"

The important part is the actionValue, which contains username/hostname. Have you changed username/hostname before?

To find msgFilterRules.dat, go to your profile directory first (can be found on More Troubleshooting Info page), then search for msgFilterRules.dat. Each account has its own msgFilterRules.dat file. Please share only the problematic ones. And also the old and new username/hostname if you still remember. Thanks.

(In reply to Ping Chen (:rnons) from comment #5)

provide the msgFilterRules.dat, this is a copy of mine

[...]
actionValue="imap://rnons@imap.localhost/INBOX"
[...]

The important part is the actionValue, which contains username/hostname. Have you changed username/hostname before?

Yes I have. This Thunderbird installation is 17 years old :)
We have changed the username and hostname several times during those years. (Also, I manage several mail accounts with it.)

To find msgFilterRules.dat, go to your profile directory first (can be found on More Troubleshooting Info page), then search for msgFilterRules.dat. Each account has its own msgFilterRules.dat file. Please share only the problematic ones. And also the old and new username/hostname if you still remember. Thanks.

Here is an abstract of actionValue from all msgFilterRules.dat (keep only authority part, removing any path/query/fragment from the URI)

cd Thunderbird/Profiles/default.1v2/Mail$ egrep -o '(actionValue="mailbox://[^/]+/)' */msgFilterRules.dat | uniq
oj@jalios.com/msgFilterRules.dat:actionValue="mailbox://olivier.jaquemet%40jalios.com@mail.exchangeincloud.com/

As you can see :

  • There is only one msgFilterRules.dat containing actionValue, it is located in an account whose folder name is oj@jalios.com (not an email address)
  • In that file, all the actionValue have the same mailbox username and hostname (I voluntarily omitted the path, which are obviously different for each rules)
  • These values (username and hostname) are the correct and last one I use.
  • My previous username may have been : jalios08, jaquemet, ...
  • My previous hostname may have been : pop.jalios.com, imap.jalios.com, ...

If that can help :

  • Filters failure : Selecting the "Inbox", and using the "Tools" menu to "Run Filters on Folder", has NO effect
  • Filters success : Opening "Message Filters" from the "Tools" menu, selecting all filters, and using "Run now" on the "Inbox" folder properly execute all the filters (this is my workaround for now)

Thank you Ping Chen for your work 👍

These values (username and hostname) are the correct and last one I use.

This is good news. So you don't see the error dialog as in comment 0? Seems you have a different bug.

  • Filters failure : Selecting the "Inbox", and using the "Tools" menu to "Run Filters on Folder", has NO effect
  • Filters success : Opening "Message Filters" from the "Tools" menu, selecting all filters, and using "Run now" on the "Inbox" folder properly execute all the filters (this is my workaround for now)

Do you get any logs in Message Filters > Filter Log? Do you mind filing a new bug about it? Thanks.

I just found that when "Manually Run" is unchecked, Tools > Run Filters on Folder has no effect as expect. In you case, is "Manually Run" checked?

So you don't see the error dialog as in comment 0? Seems you have a different bug.

Indeed. I don't have the same error message. I'm sorry, I had not correctly looked at the original posters' symptoms.

Do you get any logs in Message Filters > Filter Log?

I do get some logs.

Do you mind filing a new bug about it? Thanks.

Sure : see bug #1778064

I just found that when "Manually Run" is unchecked, Tools > Run Filters on Folder has no effect as expect. In you case, is "Manually Run" checked?

"Manually Run" is checked on all my filter

Blocks: tb102found
(In reply to Ping Chen (:rnons) from comment #5)
> Thanks for reporting. It's helpful if you can provide the `msgFilterRules.dat`, this is a copy of mine
> 
> ```
> version="9"
> logging="no"
> name="test"
> enabled="yes"
> type="17"
> action="Move to folder"
> actionValue="imap://rnons@imap.localhost/INBOX"
> condition="AND (subject,contains,read)"
> ```
> 
> The important part is the actionValue, which contains username/hostname. Have you changed username/hostname before?
> 
> To find `msgFilterRules.dat`, go to your profile directory first (can be found on More Troubleshooting Info page), then search for `msgFilterRules.dat`. Each account has its own msgFilterRules.dat file. Please share only the problematic ones. And also the old and new username/hostname if you still remember. Thanks.

Sorry for a late reply, dealing with all the regressions in Thunderbird 102 (as well as in Firefox 102 :( ) has dramatically reduced the time I have to deal with my actual work. I could also provide one of the effected msgFilterRules.dat files, but it's 10k/243 lines, and I do not see an "attach file" option. Should I just paste it in a reply? Well, anyway, here it is. It is the one matching to the original screenshot, though I have (tried to) edited/recreated a bunch of the rules already, so it is not quite in the same state as immediately  after the update. But some of the rules still don't get applied...

(In reply to Ping Chen (:rnons) from comment #5)

Thanks for reporting. It's helpful if you can provide the msgFilterRules.dat, this is a copy of mine

version="9"
logging="no"
name="test"
enabled="yes"
type="17"
action="Move to folder"
actionValue="imap://rnons@imap.localhost/INBOX"
condition="AND (subject,contains,read)"

The important part is the actionValue, which contains username/hostname. Have you changed username/hostname before?

To find msgFilterRules.dat, go to your profile directory first (can be found on More Troubleshooting Info page), then search for msgFilterRules.dat. Each account has its own msgFilterRules.dat file. Please share only the problematic ones. And also the old and new username/hostname if you still remember. Thanks.

Sorry for a late reply, dealing with all the regressions in Thunderbird 102 (as well as in Firefox 102 :( ) has dramatically reduced the time I have to deal with my actual work. I could also provide one of the effected msgFilterRules.dat files, but it's 10k/243 lines, and I do not see an "attach file" option. Should I just paste it in a reply? Well, anyway, here it is. It is the one matching to the original screenshot, though I have (tried to) edited/recreated a bunch of the rules already, so it is not quite in the same state as immediately after the update. But some of the rules still don't get applied...

PS: Well, tried to paste it, was told it is too large, so it would be send as an attachment, only to bomb out and tell me "try again 'late". Why am I not surprised?

(In reply to Henry Wilkes (they/them) [:henry] from comment #1)

Might be from bug 1573690 / bug 1483485 which may have caused the folder URIs to change. Not marking as regression though because this is speculative

Well, it is definitely a regression, as everything was working just perfectly fine up until the moment the 102 update was applied. Beside that there are several other issues, which also seem to be new in 102 (at least not been present/noticeable in the last +20 versions), like inconveniently forgetting the sort order in almost all (but not all) folders, across multiple accounts, different application of the thread view option, not opening up the folder list in an account AT ALL (thus prohibiting any access to any folder/filter, though that seems like a convenient way to hide all the other, before mentioned regressions)...

Severity: -- → S3

Filter errors are due to bug 1773822, read bug 1773822 comment #0. This shouldn't happen any more for people going from TB 91 to TB 102.0.1 or higher.

Agreed, duping this to bug 1773822.
Please reopen if someone can reproduce upgrading from 91 to 102.0.1 or higher (not .0).

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1773822

(In reply to Magnus Melin [:mkmelin] from comment #13)

Agreed, duping this to bug 1773822.
Please reopen if someone can reproduce upgrading from 91 to 102.0.1 or higher (not .0).

*** This bug has been marked as a duplicate of bug 1773822 ***

Sorry, but there was no "loss of MSF file" when I got the filter errors.

As I mentioned in my initial bug report, I could get the error about the "folder missing", while it was clearly there.
I could immediately drag a message that should have been filtered into the folder or simply edit the rule (or recreate it) and the rule would work just fine, both would rather indicate that the MSF for that folder in fact DID exist...

Is this reproducible? If so, please switch on filter logging and provide the log file. There could be many issues, like what was pointed out in comment #1. Lost MSF files certainly have cause filtering issues, maybe not in your case.

(In reply to newsfan from comment #15)

Is this reproducible? If so, please switch on filter logging and provide the log file. There could be many issues, like what was pointed out in comment #1. Lost MSF files certainly have cause filtering issues, maybe not in your case.

Neither of the things mentioned in comment #1 did apply. (Those filters were literally working minutes before I did the update)

I can't reproduce this right now, as all of my PCs (laptops) that I have currently with me are updated to 102.0.2 by now, as mentioned, I have work to get done.
I probably could reproduce this with one of those machines that I have in storage (I am currently "between apartments"), with a slim chance that I might be able to get one of my other laptops out of storage over the weekend, the earliest...

A few problems people are seeing were caused by a re-write of the so called folder cache. There are still some bugs in the pipeline to iron out more wrinkles. So essentially redoing an update from TB 91.x for test purposes would make more sense in a few weeks with forthcoming version 102.1 or 102.2 which will hopefully restore TB 91 behaviour in this respect. As a minimum, you should wait for 102.0.3 which will ship a fix to a bug that caused mbox and MSF corruption.

Hmm, I've just reproduced the filter issue by deliberately removing the target folder's MSF file. The message issued is:
The messages could not be filtered to folder 'XXX' because adding a message to it failed. Verify that the folder is displaying properly or try to repair it from the folder properties.
That's different to the message you received. It's certainly worth re-testing in a few weeks time.

(In reply to newsfan from comment #18)

Hmm, I've just reproduced the filter issue by deliberately removing the target folder's MSF file. The message issued is:
The messages could not be filtered to folder 'XXX' because adding a message to it failed. Verify that the folder is displaying properly or try to repair it from the folder properties.
That's different to the message you received. It's certainly worth re-testing in a few weeks time.

Ok, I am not sure if I can get to the storage this weekend to pull at least one of those machines, but hen it would be next week. In either case, I won't start Tbird until 102.0.3 is out.
Could you please advise exactly where and what should be enabled in terms of logging those filters running (or not)?

There is a "Filter Log" button on the panel that lets you enable the logging.

Regressed by: 418551
Summary: After Tbird 102 Update, Mail filters are screwed up → After Tbird 102 Update, Mail filters are screwed up. "folder xxxx not found...so the filter(s) associated with this folder will be disabled"
You need to log in before you can comment on or make changes to this bug.