Closed Bug 1777765 Opened 2 years ago Closed 2 years ago

Progress display bar missing when fetching pop3 messages

Categories

(MailNews Core :: Networking: POP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ fixed, thunderbird103 wontfix, thunderbird104 fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr102 + fixed
thunderbird103 --- wontfix
thunderbird104 --- fixed

People

(Reporter: dannyfox, Assigned: rnons)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

Send yourself a message with an attachment of a few MB.
Click on the GET MESSAGES button. (Or the individual mailbox...)

Actual results:

The message fetch progress display bar is not displayed on TB's bottom status line.
(i) When getting all messages, there is no indication of how the overall fetch process is proceeding.
(ii) When downloading a specific large message, no progress is shown.

Expected results:

In case (i), if there are several mailboxes being polled, users want a sense of how far through the list we've polled. (Yes, a normally quick succession of displays may show that something is happening, but not all computers on all networks get instant responses. One of my machines polls over 15 mailboxes in a few seconds, while the other lazily checks and could take a minute or two.)

In case (ii), users want to know how much has downloaded and how much remains, especially for messages with large attachments. Otherwise, it looks like the download has frozen!

There is a bug report that also mentions download activity is missing from activity manager.
I wonder if these are related.

Component: Untriaged → Message Compose Window
Blocks: tb102found

Just a follow-up in light of the more serious issues of messages being corrupted and/or lost by compacting and repair: Without the progress display, most times it is hard to know if anything is actually happening -- and I think this might be hindering some testing and debugging efforts.

Bug still present -- progress bar still missing in action -- in TB 102.0.3 Release.

Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: regression
Regressed by: pop3-js
Target Milestone: --- → 104 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/f883e519b239
Show progress bar when downloading pop3 messages. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Summary: Progress display bar missing when fetching messages → Progress display bar missing when fetching pop3 messages

Comment on attachment 9286579 [details]
Bug 1777765 - Show progress bar when downloading pop3 messages. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1707548
User impact if declined: No progress bar when downloading pop3 messages
Testing completed (on c-c, etc.): beta
Risk to taking this patch (and alternatives if risky): low

Attachment #9286579 - Flags: approval-comm-esr102?

Thanks, guys. So, in calendar terms, how soon might we see the progress bar re-appear?

Comment on attachment 9286579 [details]
Bug 1777765 - Show progress bar when downloading pop3 messages. r=mkmelin

[Triage Comment]
Approved for esr102

(In reply to Dan Pernokis from comment #7)

Thanks, guys. So, in calendar terms, how soon might we see the progress bar re-appear?

When the release ships

Attachment #9286579 - Flags: approval-comm-esr102? → approval-comm-esr102+
Blocks: 1780944
Regressions: 1783552

(In reply to Dan Pernokis from comment #7)

Thanks, guys. So, in calendar terms, how soon might we see the progress bar re-appear?

Component: Message Compose Window → Networking: POP
Product: Thunderbird → MailNews Core
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED

I tested 102.1.2 with the backout - download message body worked.
Beta and nightly are still broken.

Is there a test to cover "Download the rest of the message."?

Will work on adding a test later today.

(In reply to Ping Chen (:rnons) from comment #13)

Will work on adding a test later today.

Flags: needinfo?(remotenonsense)

Comment on attachment 9286579 [details]
Bug 1777765 - Show progress bar when downloading pop3 messages. r=mkmelin

[Triage Comment]
Approved to re-land on beta with bug 1783552.

Attachment #9286579 - Flags: approval-comm-beta+

(In reply to Wayne Mery (:wsmwk) from comment #15)

(In reply to Ping Chen (:rnons) from comment #13)

Will work on adding a test later today.

It's added in bug 1783552.

Thanks Rob.

Flags: needinfo?(remotenonsense)
You need to log in before you can comment on or make changes to this bug.