Closed Bug 1778003 Opened 1 month ago Closed 1 month ago

"Compact folder" doesn't work in Thunderbird 102.0

Categories

(MailNews Core :: Database, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1776727

People

(Reporter: siliconjon48, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

I'm using TB102.0 in Windows10. I use the Server Setting "When I delete a message: Just mark it as deleted". When I right click on a mail folder and click "Compact" an nstmp is generated but the folder is not compacted and the nstmp is not deleted. This failure to compact a mail folder has only manifested with this new release (102.0).
On all earlier releases the nstmp would be generated, then this compacted file would replace the mail folder and the nstmp would be deleted.

Actual results:

An nstmp is generated but the folder is not compacted and the nstmp is not deleted.

Expected results:

The mail folder should be compacted and the nstmp should be deleted

Summary: "Compact folder" doesn't work in Tunderbird 102.0 → "Compact folder" doesn't work in Thunderbird 102.0
Blocks: tb102found

I confirm Jonathan Edwards report.

To read my work emails I use Thunderbird 102 Release Version on macOS as well as a webmail system (Horde, I know it's old and ugly but I can't do anything about that).

Before 102, whenever I compacted folders in Thunderbird all emails deleted in Thunderbird were also removed from the webmail view.
After updating to Thunderbird to 102, folder compaction does not work anymore and all deleted emails (in Thunderbird) appear crossed out in the webmail view but still accessible.

Deleting the Trash folder either in Thunderbird and in the webmail doesn't help.

A short follow up to my previous post.

What actually happens in 102 is slightly different from what I have reported in the previous post.

Before Thunderbird 102, whenever I deleted an email or moved it to a folder within the Local Folders, it appeared crossed out in the webmail and only a folder compaction made these emails disappear from the webmail view.

With Thunderbird 102, if I delete an email in Thunderbird it immediately disappears also from the webmail view (good!),
but if I move an email to a folder within the Local Folders, the email is simply crossed out in the webmail and does not go away by issuing the Compact Folders command.

Sorry for the previous inaccuracy but it seems I cannot edit my own posts.

Thanks Jonathan and briand06. Compact seems to have issues. Same issue as bug 1776727?

Component: Untriaged → Database
Product: Thunderbird → MailNews Core
See Also: → 1776727

(In reply to Thomas D. (:thomas8) from comment #3)

Thanks Jonathan and briand06. Compact seems to have issues. Same issue as bug 1776727?

I think this issue is slightly different from what is described in 1776727 because in the case discussed here the bug occurs only when the email is moved to a Local Folder on the macOS host, thus removing it from the Inbox located on the email server.

I have just checked again and I can confirm that if the email is deleted (not moved) from the server Inbox, it immediately disappears also from the webmail view (before 102 it was simply crossed out and I needed to compact folders to make it disappear from the webmail view).

As a quick update, I have noticed that if I restart Thunderbird after having issued the Compact Folders command, all the emails moved from the server Inbox to the Local Folders disappear from the webmail view, which is the expected behaviour. This could be used as a quick fix to this issue (with the hassle of having to restart Thunderbird just to "clean" the server Inbox view).

I'm experiencing a similar issue, but it appears that Thunderbird (starting with desktop version 102.0.0 and continuing with 102.0.1) is not compacting the folders when I manually approve the action. Everything looks the same as earlier versions, and it appears that files are being deleted. I have checked the size of my Inbox before and "after" compacting, and the size is dropping by about 1 MB instead of the 100 MB minimum size I have set for requesting compaction. So the question about compacting keeps coming up, and each time the size of the expected compaction is growing (started after 100 MB, now up to +400 MB). I am not doing anything differently than I was prior to loading 102.0.0.

See Also: → 1779273

As filed, this bug very likely is bug 1776727 so going to dupe.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1776727
Keywords: regression
You need to log in before you can comment on or make changes to this bug.