Closed Bug 1778221 Opened 1 month ago Closed 1 month ago

After TB102 update -- AppMenu display cut off

Categories

(Thunderbird :: Toolbars and Tabs, defect)

Thunderbird 102
x86_64
Windows 10
defect

Tracking

(thunderbird_esr102? fixed, thunderbird103? fixed)

RESOLVED FIXED
104 Branch
Tracking Status
thunderbird_esr102 ? fixed
thunderbird103 ? fixed

People

(Reporter: rajduc, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

Customize Menu Bar to place app menu icon (aka hamburger icon) to the far left. Click to open up app menu to see pop up is cut off to its left, whether in full screen mode or resized mode.

Actual results:

Thunderbird 102 must not recognize my display size and/or the scaling that is set on my Win10 install, currently set to 125%. Using native display resolution, which is FHD (1920 x 1080).

Expected results:

It should not be cut-off.

Component: Untriaged → Toolbars and Tabs
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: After TB102 update -- Hamburger menu display cut off → After TB102 update -- AppMenu display cut off
Blocks: tb102found

I recall seeing a recent (bug?) report about File menu being offset by the spaces toolbar - I can't find it right now.
Will that bug also fix this

Flags: needinfo?(alessandro)

The spaces toolbar shouldn't affect this.
The app menu cutting outside the visible screen seems to me like an m-c styling issue of the popup panel element.
Can you reproduce this in Firefox as well?

Gently pinging Richard to see if he can reproduce the issue.

Flags: needinfo?(alessandro) → needinfo?(richard.marti)

FX would have the same issue when the AppButton would be movable.

The problem is, that the popup opens with position="bottomcenter topright". If we could change this to position="bottomcenter topleft" when the button is placed on the left side of the toolbar. Then it would also stay inside of the TB window.

As a quick fix we could do:

#appMenu-popup {
  margin-inline-start: 0;
}

then the popup can't go off-screen on the left

Flags: needinfo?(richard.marti)

The problem is, that the popup opens with position="bottomcenter topright". If we could change this to position="bottomcenter topleft" when the button is placed on the left side of the toolbar. Then it would also stay inside of the TB window.

I don't think we can detect that easily unfortunately.
We will rebuild our toolbar for 114 so this problem won't happen, but I think your temporary solution of the inline margin is a good fix for now.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 104 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/2115178fdabd
Don't let the appMenu-popup draw off-screen. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED

Comment on attachment 9284373 [details]
Bug 1778221 - Don't let the appMenu-popup draw off-screen. r=aleca

[Approval Request Comment]
User impact if declined: the AppMenu can be partly off-screen
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9284373 - Flags: approval-comm-esr102?
Attachment #9284373 - Flags: approval-comm-beta?

Comment on attachment 9284373 [details]
Bug 1778221 - Don't let the appMenu-popup draw off-screen. r=aleca

[Triage Comment]
Approved for beta

Attachment #9284373 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9284373 [details]
Bug 1778221 - Don't let the appMenu-popup draw off-screen. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9284373 - Flags: approval-comm-esr102? → approval-comm-esr102+
You need to log in before you can comment on or make changes to this bug.