Closed Bug 1778832 Opened 5 months ago Closed 5 months ago

Message pane shows solid white if no message is selected - should respect theme background color

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

Started Thunderbird

OSX 10.15.7
TB 102.1
Theme: Dark
OSX General Settings: Dark

Tried (to no effect):
Setting browser.display.background_color and browser.display.background_color.dark #000000

(per http://forums.mozillazine.org/viewtopic.php?f=39&t=3048711)
changing start page to "about:blank" (either via settings or  config editor) and adding:
    @-moz-document url-prefix("about:blank") {
    body { background-color: black !important; }
    }
to both userChrome.css and userContent.css
(supposed to only be needed in userChrome.css)

Also per above post, tried without !important

Commented out calls to
    @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
    in both userChrome.css and userContent.css

Issue seems to have been present for quite a while. Spun up an instance of 68.12.1 (32-bit) on a Win 10 box and got the same behavior.

Actual results:

Messagepane initially shows start page, then shows solid white when switching to any folder.

Expected results:

Messagepane should show start page in any folder if no message is selected.

2022-07-11_1317_mass-mark-TB102found

Blocks: tb102found

I'm not sure I agree that's a bug.

No longer blocks: tb102found
Version: Thunderbird 102 → 68

OK, so it's a "feature"? ;)

If it's not a bug, where does one control background color of the message pane? At program startup, it's whatever the start page is set to, but subsequently choosing any folder causes it to be solid white until a message within that folder is selected. Seems the message pane background should follow the chosen theme. Am using the standard dark theme. All other panes have a dark background. Message pane (with no message selected) does not.

Component: Mail Window Front End → Theme
Summary: Message pane shows solid white if no message is selected → Message pane shows solid white if no message is selected - should respect theme background color

I apologize for any confusion. This was just PEBKAC.

Have been basically running on the same profile since '06 or so, across various machines and OS's.

(One of the great things about TB. Just drop it in a new machine, update profiles.ini, and off you go.)

The chrome folder had both userChrome.css and userContent.css, which I thought were just part of the base install. No clue when they got added.

Removingg both of those got rid of the solid white background when choosing any folder after startup.

Had poked at both those files; still not sure why the white background was occurring, but it's gone now.

Please close!

Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.