Closed Bug 1778871 Opened 7 months ago Closed 5 months ago

No option to show containing address book for 'All Address Books' in vertical layout

Categories

(Thunderbird :: Address Book, defect, P3)

Thunderbird 102

Tracking

(thunderbird_esr102+ fixed)

RESOLVED FIXED
105 Branch
Tracking Status
thunderbird_esr102 + fixed

People

(Reporter: thoste, Assigned: u695164)

References

(Blocks 2 open bugs)

Details

(Keywords: ux-consistency, ux-control, ux-error-prevention)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

I have multiple (~15) address books.

When I search for a contact in "All Address Books" then the result in vertical layout does not shown in exactly which Address Book the contact was found.

Users have to switch to horizontal layout and enable the column "Address Book".

Actual results:

see above

Expected results:

Address Book vertical layout should show for each contact the Address Book which contains the contact

Blocks: tb102found
Type: enhancement → defect
Component: Untriaged → Address Book
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: New address book: Show current address book in vertical layout → No option to show containing address book for 'All Address Books' in vertical layout
Whiteboard: ux-control, ux-error-prevention, ux-consistency

Yes Thomas S. (reporter)!

Currently there's no way at all for All Address Books in vertical layout to see the containing address book. Containing AB looks like important information which should also be available in vertical view (which is default view) - I agree with Wayne and Anje that this feels buggy and incomplete (only workaround: horizontal view).

  • Showing the containing address book in the results list should be optional, to avoid perma-clutter for other users who may not need this.
  • We could just add a Show Address Book checkbox menu item under List display options (see mockup screenshot).
  • The menu option should only be shown when All Address Books node is selected in vertical layout, otherwise hidden.

Alex, what do you think?

Flags: needinfo?(alessandro)

Yeah, I think the proposed solution in comment 2 is sensible and we could implement it.
We used to show it before alongside the name, but indeed it was creating clutter and cutting off long names.

Another addition could be to hide it when the contact is hovered so users can read the full name.
Assigning this to Nicolai.

Assignee: nobody → nicolai
Flags: needinfo?(alessandro)
Whiteboard: ux-control, ux-error-prevention, ux-consistency
Status: NEW → ASSIGNED
Target Milestone: --- → 105 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fa3940dc093f
Add option to show address book for All Address Book in vertical view. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED

I backed this out. The test you added is broken on macOS and the brokenness is present in your Try run. Pushing to Try is pointless if you're not going to look carefully at the results.

Backout: https://hg.mozilla.org/comm-central/rev/86448f07127a7d51e8149b65022442b1df6f8db3

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/0265f15d6bd4
Add option to show address book for All Address Book in vertical view. r=aleca

Status: REOPENED → RESOLVED
Closed: 6 months ago5 months ago
Resolution: --- → FIXED

Comment on attachment 9289220 [details]
Bug 1778871 - Add option to show address book for All Address Book in vertical view. r=aleca

[Approval Request Comment]
Regression caused by (bug #): new ab
User impact if declined: per bug desc
Testing completed (on c-c, etc.): beta since long
Risk to taking this patch (and alternatives if risky): safe

Attachment #9289220 - Flags: approval-comm-esr102?

Comment on attachment 9289220 [details]
Bug 1778871 - Add option to show address book for All Address Book in vertical view. r=aleca

[Triage Comment]
Approved for esr102

Attachment #9289220 - Flags: approval-comm-esr102? → approval-comm-esr102+

Confirm this is fixed. Many Thanks.

You need to log in before you can comment on or make changes to this bug.