Closed Bug 1778885 Opened 1 month ago Closed 1 month ago

email date changes when moving folders or downloading mailbox to new pc

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: i235711, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.114 Safari/537.36 Edg/103.0.1264.49

Steps to reproduce:

Move an email between folders, or download mailbox to a new PC

Actual results:

When moving email from one folder to another, the date the email was received displays the current date and time. This happens whether moving the email from one folder to another or downloading the mailbox again. It doesn't happen with all email and has started since upgrading to TB102.

I logged into my webmail and the email has the correct date on the server, so this is an issue within TB102.

Expected results:

The date the email was received should be displayed correctly.

Blocks: tb102found
Component: Untriaged → Folder and Message Lists

I've checked the headers of the email experiencing this problem, and observed they are all missing the date sent in the email header. When the email is downloaded from the imap server TB assigns the current date/time to the email. When the email is moved to a different folder or mailbox it downloads again and the date appears to change...

Anyway, not a bug, the issue is with the sender.

The following preference 'mailnews.customHeaders' was set to 'Folder'. Changing to 'Received' appears to have resolved the issue after downloading the mailbox again.

-> INVALID per comment 1.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.