Closed Bug 1779319 Opened 2 years ago Closed 2 years ago

Address Book: "Get Map" button is not shown for home addresses

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

defect

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
Future
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: njsg, Assigned: njsg)

References

Details

(Whiteboard: SM2.53.14)

Attachments

(1 file)

When displaying contacts/cards, the Address Book can show "Get Map" buttons for street addresses which are set, but currently (I've been testing with 2.53.12 and a 2.53.13b1pre build) it will only show this button for the work address.

This appears to be caused by the changes in bug 1428100. For both Home/Private and Work contact sections, there is a variable that signals whether there is content to display so far. In both SeaMonkey and Thunderbird, this variable is named "visible" for the Home/Private section and "addressVisible" for the Work section, but the suite/ part of the patch uses "addressVisible" for both sections.

Assignee: nobody → nunojsg
Status: NEW → ASSIGNED
Attachment #9285251 - Flags: review?(iannbugzilla)
Whiteboard: SM2.53.14
Version: SeaMonkey 2.53 Branch → Trunk

Comment on attachment 9285251 [details] [diff] [review]
1779319-get-map-addressVisible

Stealing review. LGTM

Attachment #9285251 - Flags: review?(iannbugzilla)
Attachment #9285251 - Flags: review+
Attachment #9285251 - Flags: approval-comm-release+
Attachment #9285251 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c19375099a8b
Address Book: Unhide "Get Map" button for Home addresses. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: