Closed Bug 1779367 Opened 1 month ago Closed 27 days ago

MOZ_CRASH(IPC message size is too large) when capturing a profile

Categories

(Core :: Gecko Profiler, defect, P2)

defect

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: gerald, Assigned: gerald)

References

(Blocks 2 open bugs)

Details

Crash Data

Attachments

(2 files)

Depends on: 1779685

Instead of trying to send a too-big message, send a short message starting
with '*', which the parent can put into the profileGatheringLog.

Depends on D152026

Assignee: nobody → gsquelart
Status: NEW → ASSIGNED

Instead of trying to create a too-big shmem, or if the shmem creation fails,
send a short message starting with '*', which the parent can put into the
profileGatheringLog.

Depends on D152027

Blocks: 1780330
Pushed by gsquelart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a58be620f788
Don't send shutdown profiles that don't fit in an IPC message - r=florian
https://hg.mozilla.org/integration/autoland/rev/70cacc19a882
If a shmem cannot be created for a child profile, send a message instead - r=florian
Status: ASSIGNED → RESOLVED
Closed: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Duplicate of this bug: 1761578

Copying crash signatures from duplicate bugs.

Crash Signature: [@ mozilla::ipc::MessageChannel::Send | mozilla::dom::PContentChild::SendShutdownProfile | IPC_Message_Name=PContent::Msg_ShutdownProfile] [@ mozilla::ipc::PortLink::SendMessage | IPC_Message_Name=PContent::Msg_ShutdownProfile]
You need to log in before you can comment on or make changes to this bug.