Closed Bug 1779814 Opened 24 days ago Closed 14 days ago

Address Book Contact Address fields insuffient lines and map missing.

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1781076

People

(Reporter: anjeyelf, Unassigned)

References

Details

Windows 10
Version 102.0.2

English British version, but should assume they might add non british addresses.
Address Book
New/Edit contact
Address fields omit required lines and no map

Street address
additional address line (missing - some addresses need additional line)
Town/City (currently says City)
County/Region (currently says Region)
PostCode/Zipcode (Currently says Postcode)
Country

Many businesses are located on 'Industrial Estates'
eg: Unit number + street, name of industrial estate, town, county, postcode, country

Many addresses are also on housing estates or as in many cities - boroughs
eg: number + street, Hounslow, London. postcode, country
that second address line is not an enhancement, it is vital.

Map is missing.
No ability to set a map for longitude/latitude.
Businesses use map eg: holiday rental location or homes in rural areas require Latitude-Longitude map to locate
All my previous map data is now missing.

Blocks: tb102found

Hey Anje!

Thank you for scrutinizing 102!
Wearing my QA hat, I've been at the forefront of trying to ensure the best possible address book UX.
However, due to time constraints, address book may still have some rough edges. I've also filed many and hope we can address more of those as we go along; note that Alessandro (:aleca) makes the final calls as UX lead. Also note that we may have bigger fish to fry like bug 1777738, and very soon, new features for 114.

Wrt street address extra line, please note:

  • Have you seen my related Bug 1779567 - Reversed order of primary street address and extended address after update to 102? extended address data from existing contacts will currently still show up in its own Extended address field, but may decide to merge that into multiline Street Address.
  • Street address field is now multiline - full flexibility for users to enter any multiline address data in the order they require.
  • Use of extended address field (as a separate field) is discouraged by standards: Bug 1779567 Comment 2.

Bottom line: no data lost, multiline street address data can be entered, but for best standards compliance, we won't bring back a separate extended address field for new contacts (so that part of your bug would be invalid/wontfix imo).

All my previous map data is now missing.

I'm not sure what you mean. IIuc, we've never saved map data on contacts.
We had a Get Map button which used to open the contact's address in Google Maps or OpenStreetMap - that button is now missing (not sure why). Is that what you're after?

Flags: needinfo?(anjeyelf)

Btw, one issue per bug please... ;-)

See Also: → 1779567

Great overview and feedback from Thomas, as usual his replies are spot on!

Street address
additional address line (missing - some addresses need additional line)

As Thomas said, the street address is multiline and users can now write and format the data the way they want or need.

Town/City (currently says City)
County/Region (currently says Region)
PostCode/Zipcode (Currently says Postcode)

This is mostly a translation issue and every locale has its own way of writing those strings. We use the default American/English, which uses:

  • City
  • State/Province
  • ZIP/Postal code
  • Country

Translators can change those strings to better match their locales.

IMHO, these are not issues.

The only relevant issue reported here is the missing "Map" feature from the old address book.
We didn't add that back because we need more work and a better integration in order to put that back.

(In reply to Alessandro Castellani [:aleca] from comment #3)

We didn't add that back because we need more work and a better integration in order to put that back.

Understood.

I'm only adding this extra comment just in case someone finds this bug - they can use it as temp workaround.
It is possible to insert something like this into 'Web Sites' field.
http://maps.google.com/?q=<lat>,<long> and then enter suitable latitude and longitude data as appropriate.

Flags: needinfo?(anjeyelf)

(In reply to Alessandro Castellani [:aleca] from comment #3)

Great overview and feedback from Thomas, as usual his replies are spot on!
...
The only relevant issue reported here is the missing "Map" feature from the old address book.
We didn't add that back because we need more work and a better integration in order to put that back.

I've filed this cleanly as bug 1781076.
Thanks again Anje for your input!

No longer blocks: tb102found
Status: NEW → RESOLVED
Closed: 14 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1781076
You need to log in before you can comment on or make changes to this bug.