Closed Bug 1782056 Opened 2 months ago Closed 2 months ago

[macOS] Picture in picture mode always open in full screen

Categories

(Toolkit :: Picture-in-Picture, defect)

Firefox 104
defect

Tracking

()

RESOLVED DUPLICATE of bug 1781830
Tracking Status
firefox103 --- affected

People

(Reporter: s21330, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:104.0) Gecko/20100101 Firefox/104.0

Steps to reproduce:

  1. Open firefox in full screen mode on macos
  2. Open a website with video media like youtube
  3. Click the picture in picture icon
    4

Actual results:

firefox opens a picture in picture window in full screen.
duplicate of 1644212, it didn't happen until version 103 for me

Expected results:

open a smaller window which will popup on the full screen firefox app

The Bugbug bot thinks this bug should belong to the 'Toolkit::Video/Audio Controls' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit
Component: Video/Audio Controls → Picture-in-Picture
See Also: → 1644212
Depends on: 1781830
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
No longer depends on: 1781830
Resolution: --- → DUPLICATE
Duplicate of bug: 1781830
You need to log in before you can comment on or make changes to this bug.