Closed Bug 1783566 Opened 2 months ago Closed 2 months ago

Color selection text in the urlbar does not match Firefox's dark mode

Categories

(Core :: Widget: Win32, defect)

defect

Tracking

()

VERIFIED FIXED
105 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- verified

People

(Reporter: itiel_yn8, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR using Windows 10:

  1. Enable dark mode in about:addons
  2. Write anything in the urlbar
  3. Ctrl+A to select that text

The color selection text should be colored teal, instead it's blue (assumingly whatever is set as my Windows' accent color)

:emilio, since you are the author of the regressor, bug 1782858, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

I accidentally changed it for the highlight / highlighttext colors.

Attachment #9288771 - Attachment description: Bug 1783566 - Restore dark selection color behavior after bug 1782858. r=dao,spohl,mstange → Bug 1783566 - Restore dark highlight/selecteditem color behavior after bug 1782858. r=dao,spohl,mstange
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1d670bfae76
Restore dark highlight/selecteditem color behavior after bug 1782858. r=mstange
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
QA Whiteboard: [qa-105b-p2]

I managed to reproduce this issue on a 2022-08-07 Nightly build on Windows 10 using the STR from the Description. Verified as fixed on Firefox 105.0b5(build ID: 20220830185924) and Nightly 106.0a1(build ID: 20220831215447) on Windows 10.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-105b-p2]
You need to log in before you can comment on or make changes to this bug.