Copying from moz to other Mac apps loses formatting

RESOLVED DUPLICATE of bug 79864

Status

()

Core
Editor
--
minor
RESOLVED DUPLICATE of bug 79864
16 years ago
15 years ago

People

(Reporter: Jeff Lovell, Assigned: Joe Francis)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When copying formatted text from Mozilla or Chimera (current versions for each),
formatting is lost when pasting that text into an HTML email.  IE handles this
properly, though I still hate to use that slow POS.

Comment 1

16 years ago
-> editor
Assignee: aaronl → syd
Component: Accessibility APIs → Editor: Composer
QA Contact: dsirnapalli → sujay

Comment 2

16 years ago
Jeff, what build ID are you reporting this bug against?
(Reporter)

Comment 3

16 years ago
Mozilla 1.2b

Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

Comment 4

16 years ago
WorksForMe using FizzillaCFM/2002103011 on 10.1.5.

Comment 5

16 years ago
--> akkana

potential mail news composer issue
Assignee: syd → akkana
Keywords: nsbeta1+
Confirming with 2002122508 trunk build (Mac OS X)

This is not a problem with the MailNews, this is a problem with with "Copy".  If
I copy from Mozilla to another application (such as Eudora) I have the same
problem.  All text shows up as Lucida Grande (11 pt) when pasted, no matter what
font it was really in when you copied it.  This includes the text in the URL
bar, and text generated by control-click Copy URL to Clipboard, which *should*
be getting put on the clipboard without any formatting (so it'll show up in the
destination app's default font).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
A more specific description, with a test page and instructions on what to
select, where to paste, what is expected, and what actually happens (see the
bugzilla helper page for some hints on format) would be very helpful here. 
Also, has anyone established whether this is mac specific?

As it is, the bug is too vague for me to know what to do with it, but Joe is
probably the best owner.  Joe, do you know of any still-open bugs related to this?
Assignee: akkana → jfrancis
(Assignee)

Comment 8

16 years ago
I can't even tell what the target of the paste is.  Is the paste happening in
mozilla?  this bug is on a fast track to WFM without additional info.
(Reporter)

Comment 9

16 years ago
The problem is when trying to copy text from Chimera v0.6, then pasting it into Entourage v.X.  The font size, attributes, etc., are lost.  I have tried trashing preferences to see if that was the problem, but no luck.

Comment 10

16 years ago
We don't convert HTML styles to Mac OS clipboard styles, and it's unlikely that
we ever will.
(Reporter)

Comment 11

16 years ago
Copying formatted text to the Mac clipboard is something all other Mac browsers do (IE, iCab, Safari).  If Chimera and/or Mozilla won't implement features that users want, then users probably will use a different browser.  I just submitted this to help in development.

Updated

16 years ago
Component: Editor: Composer → Editor: Core
(Assignee)

Comment 12

16 years ago
Jeff, thanks for submitting this bug.  I would like to see this fixed as well. 
I don't know that it will happen anytime soon.  It's a great opportunity for an
outside mozilla developer to make an impact!

Updated

16 years ago
Summary: Formatting lost when copying and pasting text → Copying from moz to other Mac apps loses formatting
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Updated

16 years ago
Depends on: 186550

Comment 13

16 years ago
*** Bug 199643 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
Dup.

*** This bug has been marked as a duplicate of 79864 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.