Closed Bug 1785412 Opened 2 years ago Closed 6 months ago

Ship ARIA reflection (non-idref)

Categories

(Core :: Disability Access APIs, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
119 Branch
Webcompat Priority P2
Tracking Status
relnote-firefox --- 119+
firefox119 --- fixed

People

(Reporter: twisniewski, Assigned: Jamie)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

According to MDN, Firefox does not support the ariaSelected property. This appears to be causing webcompat issues, including on an Indian government site (uucms.karnataka.gov.in), where clicking on the "student" radio button on their login page does not work properly due to their code checking for ariaSelected on anchor elements representing tabs in their UI (this was originally reported at https://webcompat.com/issues/108532).

What's the status of the ARIA attribute reflection stuff (I assume this is it?)

Apparently accessibility.ARIAReflection.enabled enables this.

Component: DOM: Selection → Disability Access APIs
Flags: needinfo?(surkov.alexander)
Flags: needinfo?(jteh)
Flags: needinfo?(jteh)
See Also: → 1628418

I'm morphing this into a bug to track shipping of ARIA reflection, since that's ultimately what this is about and we don't have one already.

Type: defect → enhancement
Depends on: 1628418
See Also: 1628418
Summary: Implement the ariaSelected DOM API → Ship ARIA reflection (non-idref)
Flags: needinfo?(surkov.alexander)

This is affecting dropdowns for the main menu on rottentomatoes.com (they're using element.ariaExpanded = "true")

Just to check – does this comment from James Teh still describe Mozilla's position on ARIA non-idref reflection? I.e. is implementation blocked on the spec issues aria#1110 and aria#1239?

It's definitely still blocked on ARIA#1110. I need to check with DOM colleagues about ARIA#1239.

Duplicate of this bug: 1814789

(In reply to James Teh [:Jamie] from comment #8)

I need to check with DOM colleagues about ARIA#1239.

We agreed that this is not a blocker for us.

Depends on: 1824980

This needs to be documented in the browser compat data (and be removed from https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features if documented there for bug 1824980).

Sebastian

Keywords: dev-doc-needed
Blocks: 1835379
Duplicate of this bug: 1837576
Duplicate of this bug: 1838185
Duplicate of this bug: 1842226

I see this has an intent to ship what was the conclusion to https://github.com/w3c/aria/issues/1110

Will firefox be matching Chrome and Safari or will it be different?

For pragmatic reasons, we will ship matching Chrome and Safari to maximise web compat. If we can get consensus on a change across the board, we'll likely try to follow. Pragmatically, though, I think this ship has probably sailed. The priority right now is to stop the web compat pain.

Assignee: nobody → jteh
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5f5a3f190fdf
Let ARIA reflection (non-idref) and default Accessibility Semantics for Custom Elements ride the trains. r=eeejay
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch

:jamie could you please consider nominating this for a relnote? https://wiki.mozilla.org/Release_Management/Release_Notes_Nomination

Flags: needinfo?(jteh)

Thanks. Shall do. That wiki page has this to say:

Note that most of the changes impacting web developers (tooling, web standard support, and new technologies) are documented on MDN which has specific pages for releases aimed at developers. The MDN team tracks these bugs with the dev-doc-needed keyword.

That could be construed as meaning that we shouldn't nominate web platform features, etc. for release notes because MDN is the more appropriate place. It might be worth clarifying the wiki page to avoid confusion here.

Flags: needinfo?(jteh)

Release Note Request (optional, but appreciated)
[Why is this notable]: New web platform feature which fixes a significant web compat issue.
[Affects Firefox for Android]: Yes.
[Suggested wording]: Web Platform: ARIA reflection for simple attributes and default Accessibility Semantics for Custom Elements are now supported. Note that this includes boolean, enum, number and string attributes, but not attributes which reference other elements.
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Web/API/Element#instance_properties_included_from_aria https://developer.mozilla.org/en-US/docs/Web/API/ElementInternals#instance_properties_included_from_aria

relnote-firefox: --- → ?

Note for MDN: This will require updates to all ARIA properties on Element and all ARIA properties on ElementInternals, as well as the Experimental Features in Firefox page.

(In reply to James Teh [:Jamie] from comment #22)

Thanks. Shall do. That wiki page has this to say:

Note that most of the changes impacting web developers (tooling, web standard support, and new technologies) are documented on MDN which has specific pages for releases aimed at developers. The MDN team tracks these bugs with the dev-doc-needed keyword.

That could be construed as meaning that we shouldn't nominate web platform features, etc. for release notes because MDN is the more appropriate place. It might be worth clarifying the wiki page to avoid confusion here.

While we're at it, maybe someone could also clarify that implementers should also add the dev-doc-needed flag when the change is facing web developers, especially new features. And also they should add it when a new feature is implemented behind a flag and name the flag, so the MDN team knows that it needs to add it to the Experimental Features in Firefox.

Sebastian

Thanks, added a note to the Fx119 Nightly release notes. Keeping the relnote? flag open to keep it on the radar for inclusion in our final release notes.

Side note: Tweaked the wording of https://wiki.mozilla.org/Release_Management/Release_Notes_Nomination based on Comment 22 and Comment 25.

See Also: → 1853209
Duplicate of this bug: 1857586
You need to log in before you can comment on or make changes to this bug.