Closed Bug 1824980 Opened 11 months ago Closed 11 months ago

Enable ARIA reflection (non-idref) on Nightly

Categories

(Core :: Disability Access APIs, task)

task

Tracking

()

RESOLVED FIXED
114 Branch
Tracking Status
firefox114 --- fixed

People

(Reporter: hsinyi, Assigned: Jamie, NeedInfo)

References

(Regressed 1 open bug)

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Jamie and I talked on slack that we think it makes sense to enable this feature on Nightly. This will help us easily track the remainder work for interop-2023 and gather user feedback in the wild, so we can start to move on gradually and hopefully prepare for the final release, especially given that there seems to be good progress on the spec issue https://github.com/w3c/aria/issues/1110 .

Blocks: 1785412

Hi Jamie, would you like to submit a patch for this?

Flags: needinfo?(jteh)

Sure. Do you know whether I need to make any changes with regard to WPT to enable those tests or the like?

Assignee: nobody → jteh
Flags: needinfo?(jteh)
Flags: needinfo?(htsai)

(In reply to James Teh [:Jamie] (away returning 12 April) from comment #2)

Sure. Do you know whether I need to make any changes with regard to WPT to enable those tests or the like?

We talked on slack. Since our plan is to enable the feature on all nightly builds (not targeting on specific testing builds), we should proceed as normal feature flipping on nightly, no wpt pref in this case.

Flags: needinfo?(htsai)
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2200dc940cc1
Enable ARIA reflection (non-idref) on Nightly. r=eeejay
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9094464c9ddc
Enable ARIA reflection (non-idref) on Nightly. r=eeejay
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/305f5743f591
Enable ARIA reflection (non-idref) on Nightly. r=eeejay
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 114 Branch

Thank you, Jamie!

Documentation changes for this can be tracked in the following GitHub issue: https://github.com/mdn/content/issues/26689

Blocks: 1790332
Regressions: 1864452
You need to log in before you can comment on or make changes to this bug.