Closed Bug 1786297 Opened 2 years ago Closed 2 years ago

Disable "QuickActions" should disable search shortcuts

Categories

(Firefox :: Address Bar, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox104 --- affected
firefox105 --- affected

People

(Reporter: aflorinescu, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Note

  • note1

Found in

  • 105.0a1 (2022-08-22)

Affected versions

  • 105.0a1 (2022-08-22)

Tested platforms

  • Affected platforms: Windows 10, Mac 11, Ubuntu 22

Steps to reproduce

  1. Nightly/New profile. (quick actions enabled by default)
  2. Navigate to about:preferences#privacy / Address Bar and disable feature by unchecking "about:preferences#privacy"
  3. New tab and type in address bar > follow by space
  4. New tab and Ctrl/cmd+k and observe the search engines.

Expected result

  • quick search shortcuts do not contain QuickActions item
  • search engines do not contain the QuickActions item
  • keyboard combination for entering QuickActions search shortcuts is disabled

Actual result

  • The options to disable "QuickActions" only disables the functionality

Regression range

  • N/A

I am also marking 104 affected since seems like the Search Shortcuts preferences contain the QuickActions Item. Dale, we should probably consider if we want/it is worth to prepare an uplift fix for a possible future dot.

Flags: needinfo?(dharvey)

I am not sure we want to do this, while it does make sense to have the shortcuts disabled if the feature is, it would mean removing the 1:1 relationship between prefs any what they control. It also means adding some complicated logic to standard firefox controls in order to handle unsupported edge cases of users tampering with about:config directly.

Will leave some time for anyone to give any more input but will be planning to resolve WONTFIX at some point, cheers

Flags: needinfo?(dharvey)

Closing out

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
No longer blocks: 1838617
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: